VPN issues with iPhone - Solved

#1

Hello,

I am having trouble connecting to an IP that’s on a VLAN (tag 44). I am able to ping the address when connecting from my Windows 10 VPN. But when I login from my iPhone VPN, I am not able to ping the address.

It did work before, but for some reason it is no longer working.

Router: Peplink Balance 20.
VPN type: L2TP with IPsec
Switch: Unifi (tag set through unifi controller)

Here are some screenshots of my setup if that can help.

Remote User Settings

image

Network Settings

VLAN Settings

Firewall Rules

Thanks!

#2

I think I figured out the issue.

I had previously logged in locally (destination of the vpn) via another vlan (for visitor wifi).

So when I logged on later through vpn from home, it might have had some trouble and caused confusion with the vlan for that.

so at the office, i logged into the main corporate wifi. I then logged in again through vpn, and it worked this time.

#3

actually, figured out the real issue.

it turned out the subnet at home was 192.168.1.1 and at work it was 192.168.1.1 as well.

so i looked it up and that can cause conflicts. i changed the vlan at work to a different subnet and it works well again now.

1 Like