VPN Connection from Window client does not resolve local hostnames


#1

Hi,

I have successfully setup a VPN connection to my peplink balance one via the Remote User Access.

The names of computers on my local network are resolved when I connect via Android but not via Windows.

I have tried enabling the Built-in WINS server and added local DNS records with just the computer name under ‘Host Name’.

On Windows 10 I tried adding the IP address of the router as DNS and WINS server.

Appreciate any tipps how to get this working.

Thanks!


#2

Just to check, is the issue that when connecting via VPN to a remote network you can’t resolve devices on the local network?

If so you might have send all traffic via VPN configured in the windows 10 VPN profile. If you want to access local devices and remote devices you’ll need to configure split tunnelling in windows 10.


#3

No, I am accessing my home network and the machines there can only be reached by their IP address, not their names. I tried the Windows 10 VPN client setting of “Use default gateway on remote network”. This did not fix it.