VPN and RDP Issues - Balance One


#1

I just purchased a Balance One last week and the initial setup went well and had no issues. Previously I was using a D-Link DIR-825 as we weren’t really quite ready to run a nice SOHO router yet.

Network is comprised of the following
Comcast Business Router - Static IP (Peplink Router IP is configured to DMZ Host)
Peplink Balance One - Static IP of 10.1.10.3 for WAN - LAN Several clients are static IP and the rest are DHCP (reserved for guest network,etc.)

Our Server is located within the subnet of the clients as we use a network drive for our accounting software. Static IP is set to 192.168.1.2

Previously I had been able to connect VPN to Server 2012 without any issues on my old router. Once connected via VPN I could RDP to any client on the network and use mapped drives.

My Goal : To get the Peplink Balance One to function as my old router did. Be able to connect VPN to my Server (Microsoft Server 2012 Essentials). I would also need to RDP any clients within the network like before.

My Problem : After configuring the correct port forwarding rules (TCP 1723 and IP 47, TCP 3389 forwarded to my server IP) I was able to dial in VPN and connect to the server. I then tried to access my network drive, no luck. No RDP either. No internet access while connected VPN to my server.

I did go into the server and re-configure Anywhere Access (client that configures VPN and website functions on Server 2012). It came up with some errors stating that there could be multiple routers within the network, and UPnP was not enabled on the router.

Next Step : Enabled UPnP, re-ran the configuration and still the same issues. Nothing shows up in the Status-> UPnP Ports Setup. I then just did manual configuration (TCP 80 and 443 to server IP).

I can access the webpage from the outside by using my external static IP. Loads just fine on mobile browser, however it displays the Peplink web login on desktop version.

I then tried what one tech recommended was to change the system admin IP address to something different, changed it to 81 and after that I was able to connect via the Server’s webpage directly from the external IP.

To test I did enable the PPTP server in Peplink, created a user, and logged on. Connected to VPN perfectly and was able to RDP to any client like before. What would be preventing the routing from router->server->back to router when connecting to the VPN on my server? Nothing has changed from before, just the router itself.

All inbound and outbound firewall access rules are allowed.

Any ideas out there on something that I may be missing?


#2

Hi,

Please open ticket here for further checking.

Anyway PPTP to Balance One is a good option for you as tested it is working fine.


#3

I submitted a ticket, also replied to your email.

Thanks for the help.