Verizon UML295 modem

I have recently purchased a Balance 20 (hardware revision: 1, firmware: 5.4.7 build 1648, modem support list: 1010) and a Verizon/Pantech UML295 modem. The UML295 seems to work fine with the Balance 20, although the modem must be plugged-in to the Balance AFTER the Balance is booted. If I connect the modem to the router and THEN power it up, the router doesn’t detect the modem. This is not a problem for me, but it could be for others. The Peplink reseller I spoke with seemed to think that the modem should work with this router even if the modem is connected to the router before power up.
In any case, the UML295 seems to work with the Balance 20 (using it to post this). Will this modem be included on Peplink’s “Modem Support List” soon? I have these devices for a few more days before they go to a branch office. Can I do anything to help get the UML295 listed as officially supported?

Thanks for the info Ralph, appreciate it. We will be adding the VZW UML295 modem to the officially supported list soon, in the meantime it’s great to know it works out of the box with our latest firmware :slight_smile:

1 Like

Thanks for the reply, Tim. These devices will be installed at a remote office on March 11th, and although the UML295 works, I’m sort of hoping that you don’t release new firmware after that which somehow makes the UML295 work even better. Although it works with the Balance 20 as is, I’d rather not install the device at a remote site and then feel like the router should have its firmware upgraded for optimal compatibility. I guess what I’m getting at is that IF by some chance it turns out that a Balance firmware change is made for it to work optimally with this modem, I hope that firmware is ready while I still have the router on my desk instead of after it’s 500 miles away. If it turns out that there is absolutely no reason at all to update the firmware as a result of the UML295 and you guys simply add it to the “supported” list, well, that would be good too. :slight_smile:

Hi Ralph, I highly doubt there will be any change to the driver itself. When a new firmware is released there is a corresponding modem list that gets updated as well. Since your setup is already working, there should be no need to have to upgrade the firmware.

1 Like

I have found one issue with the UML 295 so far. When I try to configure it as “always on” and turn on the health check, it doesn’t save that setting, but reverts back to the “remain connected” and “backup priority” of Group 1, and shuts off the health check. And, I’m not forgetting to tell it to apply changes. And, like you are experiencing, it doesn’t restart the modem. You have to unplug it, and then plug it back in. I just hope those setting don’t cause it to turn off due to inactivity.

  • Steve

Steve, this doesn’t sound like normal behavior. Please open a support ticket via this link and we can take a further look:

1 Like

Sorry for taking so long to respond. I opened a support ticket today.

Just to follow up on this, I tested the Balance 20 and the UML295 at a branch office this week. I put the ~20-user facility onto these devices for 5 hours and they worked well. I saw one glitch in which it lost connectivity and I couldn’t even access the admin interface of the Balance. A power-cycle resolved that. Apart from that glitch, it was great. CPU readings on the Balance were usually in the single digits, and DL/UL speeds tested with were good every time I checked. I’m thinking there must be a Verizon tower near this Memphis, Tennessee site; I saw speeds as high as 29 Mbps down and 14 up.
So except for one glitch, I was very happy with the performance of the Balance 20 and UML295 providing Internet connectivity for this branch office during a 5-hour test. Now these devices will sit there powered-off but ready to go in case of an extended outage of their MPLS link.

As I said before, my problem isn’t connectivity. The 4g internet speed is great. The glitch I’m having is trying to set the UML295 as “Always On” and getting the modem to do a clean reboot without having to unplug/replug it in. It acts like the router can’t write any configurations to the modem.

We will officially support the Verizon UML295 in upcoming 5.4.8 Balance / MAX series and it will be released very soon. Stay tuned. :slight_smile:

1 Like

Thanks for the information, Herman. Is there an actual change being made to the firmware as it relates to the UML295, or are you simply adding the modem to the supported modems list at the same time that the next firmware version (5.4.8) is released?

Yes. There is an actual change on the 5.4.8 firmware for the UML295.

1 Like

Is it supported in the 5.4.9 firmware?

Yes, the UML 295 should be supported with 5.4.9 firmware.

1 Like

I upgraded the Max 700 to 5.4.9 and it does not recognize the card. The dashboard shows ‘Connected’ but there is still no connections to the internet nor my Balance 380, while when using the uml290 it would show ‘Connected to Verizon Wireless’.

Please open a support ticket via our website so we can take a closer look at this. Thanks.

1 Like

Was there a resolution to wallymac’s issue? I just received my peplink 20 with 5.4.9 and the uml295 shows connected, but has a 192.168.32.x address and never connects to the internet.

There is a landing page on the UML295. You might need to configure the UML295 in order to get the internet access. You could accomplish this by logging into the landing page of the UML295 ( or

You can modify the modem configuration through the landing page and basically, you need to click the “Connect” button, or set the modem to “Auto Connect” in order to establish the connection to Verizon.

Feel free to contact us if there is any assistance needed.

1 Like

I have the Verizon Pantech UML295 and am using it with a Balance 20, V6.3.1. Via the modem’s landing page, I have it set to Auto Connect, however it does not do so. I need to go to the landing page and click “Connect” to get it to connect. It then pops up a warning page telling me that I might incur roaming charges (I am roaming in Canada on a US plan). I think perhaps this warning page is what’s preventing it from connecting automatically? FYI, I do NOT have the modem set to “Auto Connect except while roaming”. It’s set to “Auto Connect”.

Any idea how to work around this? It’s a mobile application so cell service comes and goes on a pretty regular basis, and I’m constantly having to reconnect.

Do you see the same behavior when the modem is plugged directly into your PC?

1 Like