USB Disconnecting (no device detected)

Pepwave Surf SOHO MK3 Firmware 8.0.0 build 1406
Verizon USB 730L

Periodically, 4-5 times daily, the device loses the modem then reconnects about 2 minutes later. When the modem is connected directly to a laptop, this doesn’t occur. I have reverted the firmware as far back as 6.x.x with no change. Portion of event log below.

Mar 05 11:14:45 WAN: USB connected (
Mar 05 11:14:29 WAN: Priority changed (Priority 1 - USB / Priority 2 - WAN / Disabled - Wi-Fi WAN on 2.4 GHz, Wi-Fi WAN on 5 GHz)
Mar 05 11:12:43 WAN: Priority changed (Priority 2 - WAN / Disabled - Wi-Fi WAN on 2.4 GHz, Wi-Fi WAN on 5 GHz)
Mar 05 11:12:11 WAN: USB disconnected (No device detected)
Mar 05 11:12:10 WAN: Priority changed (Priority 2 - WAN / Disabled - Wi-Fi WAN on 2.4 GHz, Wi-Fi WAN on 5 GHz)

No help here, apparently. Did you ever get this resolved? I’m having the same issue with a USB730L.

Hello and Good Day
Have you tried a different usb tether cable?
I went through several cables to get one to not do what you’re discussing. Our Surf soho is 7 feet away from Verizon jet pack… as the crow flies. I have an obsession with routing of cables, so the usb cable is 12 feet long. As I said we went through several cables. Some of them did just as you mentioned, the WAN would connect then disconnect, over and over. I actually went into my huge collection of cables and found a 12 foot usb cable and BAM worked out great and using it right now. It’s an older cable, the others were new and did not work,and I really don’t know why.
Our Verizon jet pack is the Netgear AC791L

1 Like

No joy…I replaced the 730L with a new one and tried using a USB cable instead of a direct connection. Still experimenting.

FYI, after seeing the 730L is not on their supported list of cellular modems I followed the modem support assistance link, gathered the requested diagnostics and submitted a ticket. Here’s the response:

“Unfortunately, we do not have support for the USB730L and due to issues with development for this unit we do not currently have any plans of providing support in the future.”

Apparently the 730L is too difficult for them.

I also called Verizon and they won’t support the modem if plugged into a router. That’s not surprising as it’s been their position with previous iterations of these cellular modems. It didn’t matter since Peplink supported them. Not so with this unit.

I apologize, I did not realize the USB730L modem was a direct usb connection.
Is that the only modem Verizon is offering?
Try to get an older modem and put new SIM card in it.
The AC791L works great with the Surf Soho

I am having this same problem too with the USB730L. I upgraded my modem and router almost a year ago. At the time the USB730L WAS on the SOHO MK3 Pepwave compatible list. They must have removed it. I feel cheated. Last Pepwave device I buy or recommend. BTW Pepwave moderator, I recommend $10K+ devices a year in my position at work. Words spread.

Ever stop and think it may be Verizon?
Call them and be nice.

1 Like

Actually that’s what I thought at first. I plugged the 730l directly into a laptop and had no disconnections. I am using a Jetpack now and have had no more problems.