Unexpected DNS Addresses + Ongoing DNS Issues

Hi there! Reasonably techie (sys admin) customer who uses my new Pepwave Max BR1 MK2 for full time RVing. I am still getting accustomed to the Pepwave device and understanding how I can configure it for my needs, so apologies if I am missing something here. However, I’ve had some recent issues I’m trying to address around DNS.

When I first configured my DNS, I set it to Cloudflare’s DNS service. This is personally my preferred DNS, but I am not married to it- I’m glad to use others, but I’ve had good experience with what Cloudflare offers and am generally against using the ISP’s DNS for privacy reasons. I am open to using Google DNS or another DNS as provided, but would prefer to not use my ISP’s DNS unless absolutely forced to.

(A note: I am running strictly on cellular, with T-Mobile’s prepaid 100GB plan currently being used standalone and with a Verizon unlimited data plan being added soon.)

I have started running into intermittent issues with connectivity, always revolving around DNS. I have had various errors returned from the browser, from “Bad DNS Config” errors to “Probe Not IFnished” and some other errors, but they all have involved DNS.

With that in mind, I have tried a variety of things. I have tried configuring the DNS at the SIM card level (in the SIM card details panel) and on the VLAN that all of my devices are assigned to (I’m not doing anything that isn’t default RE: routing and subnetting outside of this). Despite testing 1) Setting CF’s DNS on the subnet level and not the SIM level, 2) the reverse of that, 3) Setting Google on the subnet level and not the SIM level, 4) the reverse of THAT, 5) trying both set consistently at the subnet level and the SIM level and 6) using automatically assigned DNS from the ISP, nothing has really resolved the issue.

What’s interesting is that now, my latest test is setting the DNS for Google only at the SIM level and letting the subnet auto assign DNS, I am getting the following DNS in the Details window of the Pepwave admin panel:

The green highlighted IP addresses are what I expect to be there, but the 10.177.0.X addresses there are NOT being configured by me and I’m not sure where they’re coming from. I know those are private IP addresses, but I’m genuinely unsure what’s setting this. The VLAN is getting it’s DNS automatically and the 10.177.0.X subnet isn’t a routable subnet on this device.

With all this in mind, what are those private IP addresses and, more importantly, are they what’s causing my DNS woes?

Thanks in advance for any help you can provide!

They are very likely T-Mobiles internal DNS servers.

They will be assigned to your cellular WAN by T-Mobile as part of the DHCP IP allocation when you connect. BUT they shouldn’t be there in the UI.

This has been identified as a bug here: Manual DNS setting not overriding automatic DNS

1 Like