Transit Duo - _All_ connectivity lost - reset no help

Hello all -

I have a Max transit Duo. Purchased in July 2020, totally loving it. Firmware 8.1 (loving the GPS service - been writing scripts against that since it was available).

recently, one of the modems was acting weird - AT&T not getting an IP, and only attempting 3G - so I rebooted it, via the web UI.

It essentially never came back to life. It was the DHCP server, which is no longer giving out leases. It has two SIMs - AT&T and Verizon - neither even connect anymore.

I tried connecting locally via ethernet - no DHCP.

I manually set an IP in the correct range, still no response from the router.

I attempted factory reset, still nothing.

I did a power off-wait-15-minutes-try again… Stil nothing.

The Ethernet LAN port lights up as it has link (verified on the local side) but the MAX responds to nothing. neither of the leds associated with the SIMs/modems light up either. I’ve tried both with and without the SIMs inserted, just in case it made a difference.

The default WiFi networks don’t show up either.

Did I brick this somehow?

Forgot to mention the status LED is green. During the reset (20+ seconds) is blinks a few times, ata bout 10 seconds, but I wait until at least 20 seconds before releasing.