T-Mobile SIM not recognized

I went to my RV today for the first time in a month or two and had no internet access. Looking at the event logs it looks like the modem rebooted a month ago and since has never connected to T-Mobile again. My intention was to add a new AT&T SIM I just received but I can’t get that SIM to recognize either. They just say connecting and spin forever. I go into details for either modem and they don’t even show that they’ve recognized a card. I got the AT&T SIM to say “Obtaining IP” briefly but then it went back to “connecting”.

I was able to tether with my phone and installed the latest 8.1.1 firmware but that didn’t seem to help anything. It’s possible the AT&T card may have an activation issue but the T-Mobile one was working fine. Any help would be appreciated as the router is currently useless if I can’t get any SIM’s to work…

I think my next step would be to phone the carrier and seek assistance, as frustrating as that can often be. Have your IMEI handy when you call.

What plans are you running for each carrier? What is the network mode setting? What is the current APN for each?

So it turns out the AT&T SIM isn’t active which is why that one isn’t working. Long story but I purchased it through Mobile Must Have when I bought the router and I feel like I was completely scammed :frowning:

The T-Mobile one should be working because it was working. I know that carriers sometimes change the list of routers they allow on their network and I was mainly wondering if maybe T-Mobile was blocking pepwave routers now.

For T-Mobile I’m using a tablet plan. I was just letting the router automatically detect the SIM’s settings but I found the T-Mobile APN settings online so will try manually configuring that. Thanks for the tip! Fingers crossed :slight_smile:


T-Mobile tablet plan currently works in every Pepwave model except the Cat18.

Usually an incorrect APN will get you stuck on “Obtaining IP” rather than “Connecting.” Do you see band and signal info on the details page? As Rick suggested, might be worth a call to T-Mobile. They’ve been pretty quick about fixing issues for me. Might just need a “refresh” or whatever magic button they push.

1 Like

Thanks… I specifically avoided the CAT18 for that reason.

When I look at the details page for “Cellular 1” I don’t see anything… Back when I originally set it up it showed that it was connecting to T-Mobile but now I get nothing for either SIM. It’s acting like there’s no SIM inserted but the event log registers every time I add or remove a SIM.

I’ve also tried 3 different versions of firmware: 3.0.X, 3.1.0, and 3.1.1.

Might be helpful to post your device model. I assume you meant firmware 8.x.x, not 3.x.x?

That sounds like a modem firmware problem, but that’s above my level. Have you tried the T-Mobile SIM in both slots?

Sorry yes 8.x.x… I have a MAX Transit Duo and yes I’ve tried the SIM in all 4 slots

Ahh, not reading in either modem would make me suspect the card itself. Do you have a T-Mobile store nearby? Might be worth asking them to replace the SIM.

I was on with T-Mobile for an hour. They confirmed that I hadn’t logged in since January 23rd. They tried kicking me off the tower I was on but that didn’t help so they suggested trying a new card. Went and got a new SIM and no luck :frowning: I even removed everything from my RV and brought it home as I have a cell booster installed… The cellular modem simply doesn’t recognize that there’s a SIM installed. I filed a support ticket with Peplink. I’ll let you know the outcome.

I’ll be the 1st to admit the technical support after the sale from Mobilemusthave can be suspect if you are trying to work with some of the more advanced functions with Peplink routers & have expressed my displeasure with them on this & other forums, as well as to them directly. However, I have 2 of their AT&T SIMs (3rd party data plans) in 2 different Peplink routers. Both were installed in new Peplink products and were recognized & connected very quickly.
I do know Mobilemusthave has an email address to their data provider partner. It’s been my experience the person has been responsive to my inquiries.
While you did not go into the details of the long story, I would suspect something is amiss with your SIM.
Wishing you success in getting your device back up & running.

It sounds like my Cellular modem is bad and Peplink is going to replace the router. We have trip coming up so I ended up buying a VZW Jetpack with a 30gb pre-paid plan to get us by for the 10 day trip. I ordered a pair of TS-9 - SMA adapters and my plan is to connect the Jetpack to my roof antenna while I wait for the new router.