Surf SOHO Mk3 on 6.3.3 - VLANs on LAN ports have no connection to router


#1

So I tried setting up the Surf SOHO router for the first time, and it seemed really straightforward (other than the VLAN option being buried away in a little help menu).
So I configured two wifi networks, and 4 VLANs, and then assigned the wifi networks to VLANs and assigned LAN ports to VLANs. Since I didn’t want the VLANs able to communicate between each other, I disabled inter-VLAN routing on all of the networks except the Untagged network.

Here is where things getting messy. I have no firewall rules in place yet, because I wanted to test to make sure everything was functional before adding extra layers of complexity.
But the only LAN network that gets a connection on the router is the Untagged VLAN.
I have tried every combination of trunk and access, inter-VLAN on and off, for every VLAN to check that I hadn’t misconfigured something somewhere.
The only combinations that work are combinations that include the Untagged LAN, and then Trunk and Access are both functional.

I always hit Apply Changes, and used three different laptops to connect across all four LAN ports to eliminate the possibility of it being anything other than the router itself.

When I try to ping the router on a LAN port configured for the Untagged LAN, the packets arrived fine.
When I unplug from that port and plug into a port configured to a non-Untagged VLAN there is no response.
I spent a couple of hours on this and cannot think my way out of the problem, so I thought I would sign up and make a post.

Here are some screenshots of my settings:

Overview of Port Settings page


#2

It would only let me post the one screenshot, but I have screenshots of the Network Settings page, and the individual VLANs’ settings as well.

Network Settings page:


#3

The Untagged network’s settings (CoreNet):


#4

The first VLAN, DevicesA settings:

All of the VLANs, DevicesB through D, are identical in setup to DevicesA but with an IP address range offset.


#5

Sorry for multiple posts/replies, but I figured that more information from the start would be more helpful.


#6

In this image you have the new VLANs as Trunks on LAN port 2, so I assume you have a switch connected to that Lan Port and have assigned ports on that switch as ACCESS ports for the individual VLANs (or manually set each LAN device to use the right VLAN ID)?

Do a test. Assign DevicesA VLAN as an Access port type on LAN Port 4 and plug a Laptop in. Does it get an IP address via DHCP and can it access the internet?


#7

I had done that before, and it wasn’t working.

A few minutes before I read your reply, I upgraded the firmware to 7.0.2, and now the issue seems to be resolved. Apparently I should’ve just started with that. lol
I kind of wish I had waited to upgrade to try to figure out what the root cause was, but at the very least it seems that upgrading will fix a similar issue.
Confirmed it by testing out exactly what you had said, DevicesA on LAN1 as Access, could ping the router and reach the Internet.

Thank you very much though!