Strategies to Decrease Time To Establish PepVPN+Bridge?

I have set up a test environment in to create a very simple setup to establish a layer-2 bridge via a PepLink VPN between two UBR-LTE wired WAN ports. The setup looks like this:

PC1 ---- UBR-LTE (wan)---------------- (wan) UBR-LTE ---- PC2.

where the wan ports have hard-coded IP addresses ( and

The PePLink VPN is established between the the two devices and Layer-2 bridged to the LANs of either device to extend the network from PC1 to PC2. Simple enough.

But I am seeing it take in excess of 2 minutes for the PepVPN to be established and start passing traffic after a disconnect and reconnect of the WAN-to-WAN Ethernet cable. [Actually once the link is established, a if I unplug the WAN-to-WAN Ethernet cable for < 10 sec, the system passes data almost immediately when plugged back in. If I unplug the same cable for > 30 sec, it takes more than 2 minutes to re-establish the connection and pass data.]

Are there configuration strategies that can improve this horrible setup time?

I need to be able to remove the WAN-to-WAN link for extended periods (10’s of minutes or more) and have the PepVPN pass data almost immediately when the connection is re-made.


Make sure you are on the latest firmware. Edit the profiles so they are only using the WAN links with the active links. Disable the health checks on the WAN links.

1 Like

Unless the firmware changed in the last month, we should be up to date. We only have a single WAN so there’s no chance to consider an inactive link. And yes, we also disabled the health checks since those are primarily require internet connectivity and we don’t have that.

Do you have multiple ips configured for the tunnel (using IC2 to configure can cause that).

Did you try with only one public ip and no1 dynDNS?

1 Like

Nope, just a single IP address for each WAN interface. One of the PepVPN configurations has the “Remote Address” of the other UBR unit, and other UBR’s complementary configuration has this field blank. There is no dynamic DNS configured because everything is hard-coded with IP addresses.

Out of curiosity, did you try in fw 8.0 and compared with 8.1?

1 Like