SSL Issues


#1

Hi, I recently installed my new Balance 30 on my network and have been having some difficulties with SSL. Most websites work fine, including a couple banking sites I tried, but a few sites in particular are not working at all. Netflix will not load, nor will a shopping website staples.ca . I also had trouble with Microsoft Online Services Outlook Web Access, although I have that resolved now.

So far I have tried using high application compatibility mode in the outbound policy. I have also tried custom rules for TCP port 443 from ‘all sources’ to ‘all destinations’ in both ‘by source’ and ‘by destination’ persistence modes. I also tried custom rules for the non standard 7443 port.

Are there other standard or non standard SSL ports i could try? Does anyone have any ideas as to why this is happening?

Just to be sure I disabled the second and third WAN connections on the router and all the SSL problems disappeared. So I must be missing something or some port on the outbound policies.

Thanks for any help!


#2

As an update, I reset all the WAN connections on the router to DHCP from PPPoE and the SSL problems disappeared! This would be fine however I need the Balance to do PPPoE so I can access it from outside the LAN. The dsl modems on the WAN ports have limited firmware and cannot do port forwarding.

I am at a loss as to why the SSL issues persist in PPPoE mode and not in DHCP mode.

Suggestions are welcome! :smiley:


#3

Devin :

Maybe your ssl website are working on another port except 443. and you sould make a persistent rule for that port.


#4

I have similar issues with my model 30. In PPPoE mode, some sites just don’t work. The TCP stream stops dead after a few packets from a small (and growing) subset of websites. This happens with normal port 80 http sites. Going to dhcp mode resolves the issues. However I need to have use of PPPoE, to get this static IP up to the Peplink.

Ross


#5

Follow up: This turned out to be issues with the Auto sensing of MTU for the particular WAN. Going back to custom default 1440 avoided the issue.

Regards