SpeedFusion with WiFi WAN (Starlink) and WISP

Hi folks, I’m starting from scratch but would really love to build a ‘Starlink recipe’ of hardware/software/services that I can purchase to achieve the objective of minimizing or eliminating impacted Zoom calls and remote VDI sessions while I’m working (currently average 3+ micro outages in every zoom call with zero obstructions).

What I’ve got:

  • Starlink dish handing off 1G Ethernet, 30+ interruptions per day of 20+ seconds.
  • 15Mbps/850kbps DSL connection handing off 100M Ethernet, 3-4 interruptions per day of 60+ seconds
  • Sophos firewall with 4 Ethernet ports

Today I’m just doing gateway failover with the firewall which only helps avoid prolonged outages.

What I’m hoping to do is build something that will duplicate Zoom streams or have <2 second failover for Zoom calls and everything else just go to Starlink.

What would I need to get hardware/service wise to enable this? Looks like a Balance 20 would work, is there anything else?

What about the headend? Is that Speedstream Cloud?

Might be worth you while to use the status page to view ports/IP’s in use during a call.

The Balance20 will top out at 150Mbits… And the Spec sheet says that the SpeedFusion on a B20 won’t do bonding, or smoothing. My Starlink currently peaks in the 300Mbit range.
The Balance20X with a USB Ethernet Adapter would work and leave headroom.

SpeedFusion Cloud would be the internet endpoint of the bonded sessions. It does make Zoom and other protocols immune to the network drops. If you need to VPN back into your private network, or provide services behind the CGNAT then you would host your own SpeedFusion HUB.

With 1 server you could also look at speedify… but I think that needs multiple NIC cards on your workstation.

Thanks Paul, I think that’s exactly what I needed. I did try Speedify but for some reason kept getting little drops and glitches in the voice, so I want to try something that was hardwired and built for purpose.

I appreciate the help!

Hi Paul, can you help with this?

I keep getting this error when I connect to the Dashboard

Failed to receive DNS response from the health-check DNS servers for WAN. But public DNS server lookup test via the WAN passed. So please check the DNS server settings.

I used the health check settings you suggested - what am I missing?

Thanks

Maybe try ping instead? This seems to work for me.

For very specific reasons I don’t check DNS servers (AT&T wireless specific issues).
(many ISPs intercept DNS queries)
So I would use ping, or manually specify 8.8.8.8 and 1.1.1.1 or similar DNS server.

1 Like

thanks I will start doing that!

I thought this graph was pretty neat. Starlink has had a rough couple days, but, because of SFC my Zoom meeting never so much as stuttered. You can clearly see Starlink dropping 4 times in this time period and ATT LTE picks up the slack. :star_struck: Good stuff.

I, for one, could not work from home solely with Starlink. It’s just not there yet.

3 Likes

Spot on - one of the unwritten rules of the internet IMO - Your ISP sucks at DNS, no matter how big they are.

I’ve seen too many “outages” caused by ISP DNS misbehaving.

1 Like