SoHo firmware upgrade now no USB modem connect

Just hooked up my new Surf SoHo and everything worked well with my Sprint Netgear USB. I immediately decided to upgrade the firmware from something to 7.0.3 Build 1260, and now my USB will not connect to Internet. I’ve done a hard boot and reset, etc etc and it still says connecting after 30 minutes. Must be some new setting that needs turning on. Can someone please advise?

If you reboot the SOHO back to v6.x.x, the USB modem will be connected immediately? If so, please open ticket for us to take closer look.

1 Like

That was one of the first things I tried to do, but even reverting back to old firmware the USB would still not connect. I had to return to my old cradlepoint router. It connected immediately so it is not the modem.

Please confirm whether the Netgear modem is on our supporting list.

You may need to check the signal strength (RSRP) and signal quality (RSRQ) in your area.

1 Like

Yes, my Netgear model is in the list.

I have nearly 100% signal. The modem is working fine at the moment with a craflepoint router.

Is it possible the new firmware update changed something that prevents the modem from connecting, and I cannot return to previous firmware status?

This is not related to the firmware based on your feedback here. Please help to get the reading for signal strength (RSRP) and signal quality (RSRQ). It should available if you access to the USB modem web admin.

1 Like

State connected
Signal 100
RSSI -75 dBm
RSRP -105 dB
RSRQ -9 dB

These are from the Cradlepoint MBR1200B status screen

Thanks for the info. I would suggest open ticket for us to take closer look. Please download the Diagnostic Report immediately when you notice the USB WAN is showing “Connecting…”


1 Like

This was already done.
6 days ago I opened a ticket #779605 and still no reply. My only option to find a solution was to seek help on this forum. Almost a week later and I still have no internet connection or a reasonable suggestion to fix.

The quality and speed for support of your products leaves a lot to be desired.

Your case has been handled. The tech support provided the firmware since 6 Dec 2017 and waiting for your feedback. Can you help to check the spam folder? I will inform the tech support to follow up with you as well.


1 Like

There is only one initial email response from my ticket. I never received a follow up or firmware. My spam folder does not contain any related emails.

The day after opening ticket (Dec 5) I also sent three follow up replies to the ticket email with no response.

Hi Thad7,

Not sure why you are not receiving the email, we did respond a couple times.
We can give you a call instead to discuss your situation and get things cleared up.

1 Like