SNMP not working


#21

Tim/Ron is there any update regarding the SNMP enhanced mibs?


#22

I’m still waiting as well. Recently we bought Balance 1350’s, interestingly SNMP is working on those with the same firmware as the 380s.


#23

I just installed and tried the WhatsUp Gold. The SNMP MIB Walker works for me.


This is what I did:

  1. Created an SNMP v2 credential profile in the WhatsUp Gold.
  2. On the Peplink Balance, I enabled SNMP v2c with the same community value.
  3. Imported the Balance MIB file according to this article.
  4. Then I can walk the Object ID: 1.3.6.1.4.1.23695 with the credential profile created earlier. With a wrong credential profile selected, the Balance’s won’t respond.

Hope it helps.


#24

The problem is not that we cannot walk the mib. The MIB is very poor and provides very few to none information for the device.

Take a look at the console and you understand that the information should also be given via SNMP.
Some thoughts to innclude, CPU, uptime, bandwidth utilization, throughput, etc which are really simple and easy to gather.

Anyway I believe it is a very important matter for every organization.


#25

The good new is the following data will be available through SNMP in the coming firmware 6.1:

  • CPU
  • memory free
  • LAN status
  • modem/Wi-Fi WAN (MAX products) status
  • PepVPN/SpeedFusion VPN status

Our target release date is Q4 this year.


#26

Good stuff!
I just tried importing the MIB into PRTG. The import worked just fine and I was able to select it in PRTG. However! It says **No available interfaces on this device (code: PE049).
**
Not sure what’s going on here. I thought I tried this before and I got it to add, but actually all the values were just 0 so I stopped trying. All we’ve got right now is the ability to ping the device to check for uptime.


#27

Good day I am new at this and I would like to know so I use the snmp
regards


#28

Just tested with PRTG and sucessfully added a Balance 580 and MAX HD2 without error. The version used
is 13.3.5. I used the autodiscovery function with add sensors and it found the interfaces using the standard Interface MIB.

-Jonan


#29

Hello,

For those needing improved SNMP features you can try the following special build of firmware v5.4.9. It includes parts of the SNMP stack from the future 6.1 release:

http://download.peplink.com/firmware/plb700/fw-b380_390_580_700_710_1350-5.4.9s26-build2673.bin
http://download.peplink.com/firmware/plb700/balance_snmp_mib-5.4.9s26.tar.gz


#30

Hi,

Thank you for the mib.

Please have in mind that the CPU is not available on this mib or not supported by the firmware.
Also I believe some of the new listed OIDs are really useless since they dont provide any actual information for the device.

You can consider what really a client needs. What features are important to for us.
DNS, Speedfustion, CPU, Memore, Throughput, Uptime, Availability.

Also if possible a good thought for the future, implement a syslog feature.


#31

Hello,

CPU, memory usage, uptime, SpeedFusion, and throughput are all working with this special build firmware.
Did you upgrade to the firmware image above ? Keep in mind this is backported from beta 6.1.

Which syslog feature are you looking for ? If you mean remote syslog it is already supported.
You can find it under “System --> Event Log”

-Jonan


#32

Hi,

Yes i have updated to the firmware attached, walked the MIB and I cannot see or retrieve any CPU/memory values.
Please check also the mib to verify and let us know if you find the CPU OID.

Regarding syslog you are right :slight_smile:


#33

Hello,

The CPU information starts at OID: .1.3.6.1.4.1.2021.11

Not sure which software you are using but this data is described in the UCD-SNMP-MIB which is distributed as part of the net-snmp software.

-Jonan


#34

I’ve been watching the returned value for .1.3.6.1.4.1.2021.11.11.0 (ssCpuIdle.0) from my Balance 20 running firmware 6.2.0, and it never wavers from 96. Ever. Even when the web interface is saying the CPU Load is in double digits.

Something isn’t right here. Any guidance would be appreciated!

/Marty