Single Youtube upload killing Internet traffic

I tried that when I had the TP-Link and the Asus, the first for Dual WAN, the second for QoS. It worked, but I had all kinds of problems with the double NAT. UPNP becomes useless in this scenario.

Yep, you found the same that I did. Fwiw - Peplink only supports UPNP on the untagged LAN unless the packet has a TTL higher than 1.

Keep your head up. You are on the right track. You have the best dual wan product you can get. As time goes on - it is only get more feature rich and efficient. That is the beauty of a company that provides firmware updates regularly.

If queue management and congestion control are important to you - look in the feature requests section of the forum. Find a thread that requests that feature and then chime in on it. I don’t know what weight the engineers put on the threads comment count, but chances are that it does play some kind of factor in their decision making process. There are others that want layer 7 QOS, others want coordinated handoffs from WAPS, some are asking for easier very deployments, and probably the most requested is the support for OpenVPN. If you don’t find someone else asking for it - start up a new one.

Take a look at this post by @DocPecos - it may be able to help your situation.

BufferBloat - #3 by MikesTooLz


It’s good to know about this UPNP issue. I’m using a VLAN to provide a Guest Wireless SSID. I prefer to use the Asus for WiFi, as it has better range, but for guests I have to use Peplink since Asus guest wireless SSID does not isolate anything when it is on AP mode and it does not support user configured VLANs.

My connection is better now that I lowered the buffer size to 50. It is still slow during large uploads, but now it takes a few instead of several seconds to load a web page. So, BufferBloat is probably the main cause of the issue.

It would be nice to know what Peplink is currently addressing for the next firmware. Queue management would be the non-workaround solution for this issue. I guess it is not that difficult, as the algorithms are freely available.

I already created some feature requests, including better QoS, more groups and more priority levels. Layer 7 QoS is tricky, but more groups and priority levels is probably easy to implement as well, unless they are greedy and decide to make it as an upgrade or a feature available only on expensive models. I’ll create a feature request for queue management too.

From what I understood:

  • considering the default 2000 packets of WAN Connection Buffer Size.
  • considering a packet usually has up to 1480 bytes.

2000*1480 and we have up to 2,82 MBytes of buffer.

I have 2 Mbps and 500 Kbps of upload bandwidth in my two WAN connections, respectively.

This means I have 12 seconds and 47 seconds of buffer in each of WAN, respectively.

Unless I misunderstood something or I made some wrong calculation, this is way too much, even if we had the best queue management in the world.

Maybe Peplink made this router for connections much faster than mine. For upload speeds of 50 Mbps, which I guess is common on first-world countries, 2000 packets is only half a second of buffer, which seems just fine.

For the original question:

  • Determine what destination port is being used for the Youtube uploads. While a PC is running the upload, go to Status > Active Sessions > Search and look for the LAN address of the PC. Do this a few times as the port may change, but likely will be in a small range.

  • Once you have identified the port or range, go to QoS and create a custom rule putting that port range on a low priority

1 Like

The port is always 443. If I put it in low priority, all web traffic will be in low priority too.

It seems that changing WAN Connection Buffer Size to 40 and 10, respectively, giving each connection only about 250ms of buffer, which is the general rule of thumb, minimized the problem. Now TCP equality works and the upload and requests and ACKs from other connections have the same weight. I still have to see if there isn’t any sides effect though.

I am logged in as you described however, I do not see WAN buffer size setting as a option; is it a hidden option?

Thank you

It’s in a hidden page called support.cgi: