Setting up L2TP With IPsec

Trying to configure Ivacy VPN on my Windows. Why can’t I find the “L2TP/IPsec with pre-shared key” option in the VPN type dropdown :frowning:


Please check with your Service Provider if they can setup some type of forwarding or how you can go about getting a public IP address.

1 Like


If you’re using Windows 10, the built in client does have the L2TP w/ Pre-shared key option. If you are required to use Ivacy VPN please reach out to your local support team or to the Ivacy Support.

1 Like

Suggested to use Window 10 build in client


Guide can be found using the following post:

1 Like

I set a Peplink One with multiple WANs. One has public IP and the other has a private IP.
I can complete a VPN tunnel with the WAN with the public IP! this instruction is excellent, but…
The WAN that has a private IP, is behind a router that is forwarding a public IP, but I can not get connected.
Any particular configuration for this case with private IP on the router?
Thanks in advance

Is their any changer for this L2TP on latest firmware 7.1.2 build 4094 for BPL-ONE Hardware 3 and BPL-310 Hardware 4? I have upgraded both this model and found This L2TP can not connect.

Event Log just show:
|Mar 05 17:57:36 | L2TP/IPsec: admin disconnected (
|Mar 05 17:56:51 | L2TP/IPsec: admin connected (|

I have a Pepwave MAX HD2, i cant seem to find this option there, I assume its been taken out. the build I have is 8.0.2 build 4407

Hello @FMRC_Cheeky,
The place to setup IPSec on your Pepwave MAX is under the main menu of “Advanced” along the top & then “Remote User Access” on the left.

Happy to Help,
Marcus :slight_smile:

1 Like

LOL, if it was a snake it would have bit me, I guess I need to get more coffee LOL thanks

1 Like

What ports are needed for this setup since my Peplink device is behind the ISP router(NAT).

I believe this article should help.


Thanks. Sorted it out. For some reason I had to forward 1701 as well.

1 Like

Should this be WAN ports, rather than LAN?

@cryptotuna, thanks for reporting this. It has been changed.


Hello Alan
I own a Balance 310 with firmware 8, i have followed exactly your instructions, but when i try to connect my Macbook under Catalina (10.15.6), i got the message : LPT2 Server doesn’t answer. Can you please help me, i don’t understand what’s wrong


We are having problems with setting up L2TP with IPsec connection via Windows 10 integrated IPsec client. I followed instructions exactly, but it doesn’t work for me. In PC it just says that modem has reported error. No events seen in Peplink Event log. We have Balance 710 with 8.0.2 build 2721.

Any idea?

Kind regards

@ProjektIP, I do not see any L2TP/IPsec RUA related known issue in 8.0.2, but it might be worth to upgrade to 8.1.0 to see if that brings any difference.

If the issue persists after upgrading to firmware 8.1.0, you may submit a support ticket for the team to take a closer look.

1 Like

We upgraded to 8.1.0 build 4942 and still the same results. We will submit a ticket to find out what is going on here.

Hi, my Balance One and Mac connect fine and I can ping the Balance one and log into the Admin page, but I can’t see or get into other units on the LAN. I tried an Inbound rule (attached) and the opposite (source - destination) and one with the LAN in both source and destination, but none worked. My Mac VPN is set to send all traffic over the VPN and my Balance One Remote is set to connect to the untagged LAN.

Any thoughts? Thank you! Woodie