Samsung Galaxy TabPro 10.1 connectivity - Surf Soho


#1

Had a whale of a time getting a TabPro to connect to the Surf Soho I purchased about a month ago. Quick background info…when I got the Surf Soho, I couldn’t get my Windows 7 Pro Dell Latitude E6510’s to connect, either. Finally got the wireless security method set to WPA2 Personal & all was well. Now, w/ the TabPro, same situation. I had to root around the internet & find the last firmware they made for Android KitKat (Australian), & now the tablet finds the router, but both the signal strength & the range are in the tank. Connection regularly drops, as well. However, I can turn on the mobile wifi hotspot on my Galaxy S5 & the TabPro connects to it & runs like a dream, no issues whatsoever. Have made sundry changes in the admin console, throttling off 2.4GHz vs. 5, 802.11ac vs. 802.11ng, boost or not, nothing makes a difference.

Anyone known any magical settings to make the Surf Soho more attractive to the wifi utility on the TabPro 10.1?

Thank you!


#2

Hello @Captain_Marvel,
A few suggestions to get you started:

  • Set your country to Australia (if that is where you are), not the default US unless that is where you are, Australia has some of the world tightest RF regulations set by the ACMA and manufactures supply the different country choices so you don’t risk interfering with others (such as emergency & medical services on nearby RF bands).
  • Change your 5Hz bandwidth to 20 MHz
  • Turn off “Boost” on both 2.4Ghz & 5Ghz leaving the Wi-FI AP units on “Max”
  • Move the equipment away from other RF equipment in the area like portable phones (not talking about mobiles cell phones) & microwave ovens (you probably have already done this).
  • On a modern PC with Wi-Fi abilities (sorry this dose not run on a MAC that I’m aware of) get yourself a copy of Metageek’s inSSIDer http://www.metageek.com/products/inssider/personal/ and look at what is happening with Wi-Fi in you local vicinity, you may find all of your devices have clustered onto one channel or something else is causing the WAP to back off its power and abilities.

See how you go with all of this, others here in the Forum will be able to add to this for you also.
If the problem persists, you can also submit a support ticket with the devices diagnostic report to Peplink to see if there is anything unusual, you can also look at the event logs under Status to see if there is anything that may give you a clue as to what is happening.

Happy to Help,
Marcus :slight_smile:


#3

Hey, Marcus, you’re excellent to have pinged back so quick on this topic. Sadly, none of these tweaks changed the Galaxy TabPro 10.1’s behavior. One interesting thing to note since you recommended changing to Australia right off the bat…I spent about 8 hours resurrecting this TabPro from a bad root & OS flash. Thankfully, what finally stuck was the latest firmware from Samsung, but it’s an Australian build, if you can believe that! (But I am in the US, East Coast, mid-Atlantic) It’s Android 4.4.2, KitKat, July 2014 kernel, T5200XXUANG1; I put that in this post in case it ever helps anyone visiting the forums. Again, this is a Samsung Galaxy TabPro 10.1, model SM-T520.

Something I was never able to find in my Pepwave admin console was this setting…

Change your 5Hz bandwidth to 20 MHz

I have the 802.11ng & 802.11ac protocols & their channel widths in MHz, as well as the SSID GHz settings of 2.4 and 5, but nothing that allows me to fine tune a 5Hz bandwidth to 20MHz.

I did try changing the 802.11ac channel width fro 80MHz to 20/40MHz, as I saw that as something to try on another site’s forums, but no joy on this Samsung tablet.

Again, the tablet connects up fine w/ my Samsung Galaxy S5’s Verizon WiFi hotspot. Just not w/ this Pepwave product. I’m actually starting to see that throughput limit affecting streaming stuff from the web…let’s say someone has web stream of something going on downstairs & someone’s watching Netflix upstairs. Spectrum 100mpbs download, even used plain Jane Cisco/Linksys E3200 before this Pepwave unit & it had similar range & better throughput.

Dangit. For $200, I expected better.


#4

Wow. Well, as many of you probably surmised, this issue turned out to be w/ the Samsung tablet unit itself. But not anything I had seen anywhere online. Upon removing the back cover to the unit, I found the physical wifi card cable was UNPLUGGED from the wifi card! Interestingly enough, it was just touching the motherboard of the card to where there was technically a metal-to-metal contact…so, that’s why I was just barely picking up the signal from the Pepwave router. I was also wondering why it wasn’t picking up all the other wireless routers from my neighbors & now we know why! Works like a champ now, so suffice it to say that I’m sorry I pointed the finger of blame @ the Pepwave router. I’m very glad to have gotten your tweaks, though! That’s superb. If you will elaborate on the Change your 5Hz bandwidth to 20 MHz piece, that is much appreciated. Thank you again, sire!