RPi on wifi but not internet

Hi,
I’m new to the Pepwave set up . The Surf Solo Mk3 is running behind an ATT fixed wireless gateway with the gateway’s wifi turned off. My Solo is running firmware 8.1.1 and I am trying to do the initial set up.
I have 3 Raspberry Pi running as music streamers and one running as both streamer and music server. They all connect on wifi, in addition to my phone and a laptop. Two additional computers connect by ethernet.
The Raspberry Pi’s all show wifi connection with good signals and I can play locally stored music from the server RPi over the wifi. However, I can’t get internet radio stations. The phone and the laptop on the same wifi network can access the internet without problem. Security is set as WPA2 - personal on the router and WPA-PSK on the RPi.
This was not a problem on the ATT gateway before inserting the Solo. I have tried many things, including turning off the ATT firewall and the Solo firewall with no result. I’m not sure where to look next. Any help would be appreciated.

Are you doing any content blocking on the SOHO? If so, maybe disable that and try again.

Assuming content blocking is enabled you could also whitelist the internet radio domains and see if that gets it going.

Thank you, stego! Unchecking the audio/video box in content blocking did the trick. I thought I had left that section on factory defaults, but I probably messed it up. I have a lot to learn.

Thanks again.

1 Like