[Resolved] Slow Internet Speeds when connected to Peplink Balance 210


#1

Hi Guys,

I just recently bought a Peplink Balance 210 and have spent the last couple of days setting it up. I have two wan connections, WAN 1: Cable Connection (100mbps/2mbps) and WAN 2: ADSL2 Connection (8mbps/1mbps). We are using the WAN 1 connection as our main internet connection and have the WAN 2 connection as a backup incase the cable connection goes down.

Everything is up and running but the one issue that I have is that when we are running the WAN 1 Connection through the Peplink Balance 210 our download speeds drop from 100mbps to 30mbps. Is their a setting that we have not set up properly?

Any help would be greatly appreciated.


#2

As an update, under Physical Interface Settings I changed Speed from Auto to 100Mbps Full Dulplex. Speed is back to where it should be.


#3

Alright. Problem solved. Just a mis-config then. Enjoy your Peplink, Dean.


#4

Kurt,

One of the things that made us choose Peplink for our companies needs was the support that we saw Peplink staff offering their clients through the forum. The fact that you commented to my post even though I had sorted out the issue confirms that fact. Well done and much appreciated, it’s the small things that sometimes make the difference.

PS. Loving the new Peplink Balance 210.


#5

Thanks for your comments Dean. We take a lot of pride in our customer service and this extends to the Forum as well.


#6

I need help. I’m having the same problem with my Balance 50 router. I have 2 6mbit DSL circuits and 1 cable modem @ 50mbit/3mbit. No matter what I try, including the interface fix that is shown above, I can’t do a speed test over 6mbit down and 1 or 2 up. However using the internet with multiple sources I can almost max out the upload, but not even close on the download. I can’t break 9mbit no matter what I do. I’ve started multiple downloads, run multiple speed tests, etc. The Peplink is slowing down my connection big time. If I plug directly into the cable feed, I can clear 40mbit. Anything else to try please?


#7

Hi,

Please try with our Speed Test Tool. Please follow the instruction in knowledgebase.


#8

I ran the your speed test tool too. Same results. Barely breaking 8-9mbit when I know I should be getting at least 30mbit because the cableone connection, although rated at 50mbit, can get only 30mbit during peak times. You gotta believe me, the Peplink is slowing things down. I really don’t get why a $550 device would only be rated at 100mbit, that is silly. I know you gear toward offices, but there are home users that can’t afford the crazy higher end devices and just have normal broadband connections. TP-Link’s load balancing router is only $150 for the top of the end device and has higher throughput. I love your device feature wise, especially the live charts and graphs, but when I plug directly into the cable connection and get 30mbit then put the Balance 50 inline and drop to a max of 9mbit there is definitely something wrong


#9

I created a trouble ticket and uploaded the diagnostic report along with my other info and I turned on remote access. Also uploaded diagnostic report. Please get in contact with me when you can.


#10

Hi Aaron,

Sure. Our tech support will look into your case and feedback asap.

Thank you for help to open ticket on this problem.


#11

hello friends

i am getting same problem in peplink balance 20 can you please help me any one


#12

As mentioned in another post, please try it with a PC directly connected to the ISP modem. If need be you can open a support ticket with us for further investigation.