Port Forwarding Query


#1

I have a query relating to port forwarding on my Balance 30.

As an example say I want to forward inbound traffic on WAN2 for my <Public IP> on port 7890 to a PC on my private network <Private IP> on the same port (7890).

So this is what I have configured.

Inbound Firewall Rule (I have my default inbound firewall rule set to Deny)

Rule: Test

Protocol: TCP

WAN: WAN2

Source IP/Port: Any/Any

Destination IP/Port: <Private IP>/7890

Action: Allow

Port Forwarding Rule

Service: Test

IP Protocol: TCP

Port: 7890

Inbound IP addresses: WAN2 (<Public IP>)

Server IP Address: <Private IP>

This all works fine but I have some questions…

  • I assume I need both the inbound firewall rule and the port forwarding rule for this to work?

  • If I wanted to accept a connection on <Public IP> port 7890 but forward that to <Private IP> port 1234 (i.e. a different port) how would I configure that?

Another thing I noticed that once an inbound session is established (and visible in the Status / Active Sessions / Inbound table) how can I terminate that session? If I remove or disable the above rules this has no effect on established sessions. Surely there should be a way to terminate an active session from the GUI?


#2

Hi Ian,

here are the answers,

  • I assume I need both the inbound firewall rule and the port forwarding rule for this to work?

Yes, you would require both inbound firewall rule and the port forwarding rule for this to work

  • If I wanted to accept a connection on <Public IP> port 7890 but forward that to <Private IP> port 1234 (i.e. a different port) how would I configure that?

Currently, we do not support this feature. However it is in our roadmap.

  • Another thing I noticed that once an inbound session is established (and visible in the Status / Active Sessions / Inbound table) how can I terminate that session?

No, we cannot terminate that session for the time being. A workaround, you can add the a inbound firewall deny for that client, then apply changes and then remove the firewall deny and apply changes again.

Thanks