Peplink Balance 20 randomly crash


#1

Router Name : GWZ20PW
Product Model : Peplink Balance 20
Hardware Revision : 1
Serial Number : 1824-A4FF-8C1E
Firmware Version : 6.1.2 build 2701

Haven’t seen it for a long time on 6.1.1 firmware but no same issue again.

On applying changes to Router GUI crashed and partially connectivity lost. Offline internet via browser, but Google talk was still able to send and receive IMs

Changes was made prior crush: From Clients list added device to static DHCP lease, save, apply, done, GUI unreachable, SSH timeouts, router still pingable.

Powercycle fixed it, but why???

RA is on, feel free to mess with it.


#2
  1. Obtain a Diagnostic Report before Rebooting: When you reboot your device, valuable information about the issue could be lost. To obtain a diagnostic report, please refer to this document. - NOT POSSIBLE device unreachable.

  2. Turn On Remote Assistance: Remote Assistance enables us to better diagnose the problem. To turn on remote assistance, please refer to this document. - ON

  3. Submit a Support Ticket: This will facilitate communications between you and our support team. Please submit the ticket via http://cs.peplink.com/contact/support and specify “Beta” in the Inquiry Opened a ticket [Ticket #743577] Peplink Balance 20 randomly crash


#3

also looks like issue command on CLI breaks internet partially. Device seems online and accessible via SSH but Computers loose connectivity, WiFI seems to be still working. weird.

> system modem reset
sh: unbind: unknown operand
Usage: ./cli

./cli bandwidth.transferred
./cli bandwidth.aggregated
./cli bandwidth.wan
./cli status.clientlist
./cli status.cpuload -p NUM]
./cli status.ha
./cli status.s2svpn
./cli status.session
./cli status.wan -i CONNECTION_ID]
./cli system.debugmode
./cli system.eventlog -d] -n NUM]
./cli system.info
./cli system.reboot -y] -d NUM]
./cli system.restore
./cli system.uptime
./cli modem.reset


#4

Thank you for the feedback. We will keep you updated on our progress.


#5

Noticed something else, not sure if it will help.

Most likely to apply any changes device freshly booted it will survive it with great change but IF I want to apply some changes on unit which uptime is few days this is very like to lock up.
And sometimes before I want to do any changes I reboot unit first :slight_smile:


#6

This is good information. Engineering team is aware of this and will look into that. Thanks.


#7

Would you please upgrade to this 6.1.2s23 build 2711 special build firmware to see if the mentioned issue is solved?
We have improved the system stability:
http://download.peplink.com/firmware/plb30/fw-b20_30-6.1.2s23-build2711.bin
Thanks!


#8

testing on Balance 20s as of today. will take few days to tell if it helped.


#9

1824-B932-5DC3 balance 20 locked up on 6.1.2s23 build 2711 special build firmware

RA is on

but box is locked up and there for now diag


#10

May I know the device locked up time and symptom?
The “1824-B932-5DC3” RA is not connected to our server now, could you please check the WAN connection or re-enable R.A.
Thanks!


#11

it crashed and rebooted on it’s own couple times

try RA should be on.


#12

CPU load @ 100% all the time

> get cpuload
CPU Load: 100.00%
> get cpuload
CPU Load: 100.00%
> get cpuload
CPU Load: 100.00%
> get cpuload
CPU Load: 100.00%
> get cpuload
CPU Load: 100.00%
> get cpuload
CPU Load: 100.00%
> get cpuload
CPU Load: 100.00%
> get cpuload
CPU Load: 100.00%
> get cpuload
CPU Load: 100.00%
> get cpuload
CPU Load: 100.00%


#13

We will be releasing the firmware that fix this issue soon, will keep you informed when it is available.


#14

yep I just have similar symptoms on
Serial Number 1824-A505-72BA

Product Name Peplink Balance 20


#15

For both 1824-A505-72BA and 1824-B932-5DC3, the high CPU load problem is happening after apply changes?


#16

Nope just out of the blue, and what is strange it’s not in the middle of the day in the peak load, but actually everybody gone and no one in the office.


#17

I just experienced a ‘crash’ on my Balance 20 today while running on 6.1.2 build 2701.

I was unable to access the administration pages to obtain a diagnostic report or turn back on RA (I was turning it off and updating port forwarding rules during the last Apply ChangeS).

The system seemed to be working okay. I did notice I was sent to WAN2 for a period of time which was odd. I didn’t receive a health check email on WAN1.

I just restarted by pulling the power cord. I’m back in business.

EDIT: Actually, looks like RA is still on.


#18

@cyclops, the issue had been fixed in GA firmware build which will be publicly announced tomorrow.


#19

I believe I updated the firmware, but I went to save a new rule for forcing all connections from a source IP through a particular WAN, and the Apply Changes page seemed to time out. When I reloaded the page I cannot access the Admin configuration. Everything appears to still be working okay, but I will have to do a hard reboot tomorrow when everyone is not in the office.

EDIT: I’m back in to the admin page. Took 10-15 minutes it to allow me in.


#20

Hi Cyclops,

Can you share the firmware version and build no.? If problem persist, please open ticket here.