PEPLink 20 web console broken


#1

I’m not sure when it happened but my PEPLink Balance 20’s admin web console has stopped working. I can login fine, but there are missing images on the initial landing page that has the list of connections and their status. The “Disconnect” buttons are there, but they don’t work. None of the other pages in the console have any content at all except the toolbar at the top.

I attached two screenshots.

Note the missing green light images in the landing page.

On the next shot, I show the “System” tab. Notice the blankness below the toolbar.

Not sure how to proceed, since I can’t re-install the firmware in this state or even see what firmware is currently installed.

I have tried this from multiple computers and multiple browsers, wired and wireless, with the same result.

Strangely, the device appears to be working for the most part, though I’m trying to figure out why video conferencing is so laggy. This isn’t helping.

Any ideas? Do I need to reset to factory settings?


#2

Hi,

Appreciate if you can open ticket at http://cs.peplink.com/contact/support. We need further troubleshooting.

Thank you.


#3

Done. Ticket #741523

Thanks.