Peplink 110 with BT Cloud Voice


#1

Hi,

I have just setup BT Cloud Voice which is a voip phone system and a BT Business Hub 5 router. I plugged the hub Ethernet cable into a wan port on the peplink and then another Ethernet cable from the peplink lan port to the voip powered switch. Problem is the voip provider tells me the BT Business Hub 5 router is on the wrong side of the firewall and its causing a lot of lag.

Can anyone think of a way around this problem please? I have gotten used to the security of both a second internet connection and a 3g dongle clicking in if there is an outage.

To get over the problem so far I have had to plug the router directly into the switch. The voip provider has confirmed the lag has now gone.

Thank You

Paul


#2

Hi Paul,

  1. Are you using Balance 210?

  2. May I know what is the bandwidth of the BT WAN link?

  3. Have you check the Real-time bandwidth usage (Status > Real-Time) of the WAN that connected to Hub 5 router during problem occur? How much bandwidth was consumed?

  4. What is the Aggregated Transfer throughput (Status > Real-Time)?

  5. This happen on peak hours only?

  6. All voip phones affected?


#3

Hi TK Liew,

  1. I think so, I bought it about three years ago, it has 2 wan ports, 1 usb port and 4 lan ports. Sorry I can’t check because I am off site right now. I remember it was the entry level model at the time.

  2. With the fibre we get 40 meg download and 10 meg upload

  3. I have not checked this, but BT must have been able to ping the system as they said when plugged in to peplink the reading was about 3400 and when the router was direct to voip switch it was 120

  4. Sorry don’t know

  5. No it is all the time, even with low usage

  6. Yes, the BT support said it showed as a SIP gate ALG fault. They got me to check the BT router settings but the setting was already set to off which is correct. Here is there page on the issue: http://btbusiness.custhelp.com/app/answers/detail/a_id/34573/~/what-is-sip-alg-and-how-can-i-stop-it-causing-problems-on-cloud-voice%3F

Further information is it is a five voip system and about 6 computers. We tend only to have two or three calls going on at any one time. The computers do not do any heavy downloads just access our cloud database which is only light network traffic.

Thank You

Paul


#4

In the Balance Router, go to Network>Service Passthrough:SIP: Ensure that Compatibility Mode is selected.

Standard = SIP ALG ON
Compatibility = SIP ALG OFF


#5

Thanks Jarid, I will test out when I am back at work tomorrow.

Are there any other settings I might need to look out for please?

Also I was thinking should I let the BT Router be the DHCP server or the peplink?

The BT Router is on 192.168.1.254 and the voip switch 192.168.1.1 what ip should I put the peplink on please?

Will QOS give me any problems please?

Thank You

Paul


#6

Hi Paul,

  1. Please help to connect Hub 5 router back to B210 WAN port then disable SIP ALG on B210.

  2. Please ensure Voip traffics alway redirected to same WAN. You may use Outbound Policy to control it.

  3. The Voip switch is provided by BT as well?

  4. If Hub 5 router was connected back to B210 WAN port, B210 should act as DHCP server. Try to avoid using same (192.168.1.x) subnet between WAN and LAN port.

  5. Qos should not giving any problem.


#7

Hi TK,

  1. Ok
  2. How do you do this please, do you have an example?
  3. Yes
  4. Ok understand so if the peplink is set to 192.168.1.1 set the BT router to 192.168.2.1, is that correct please?
  5. Thanks for confirming

Thank You

Paul


#8

Hi Paul,

Firstly, since the VOIP switch is provided by BT, please confirm with them whether this connectivity is valid. I assume IP subnet for Balance’s LAN = 192.168.2.0/24 and WAN = 192.168.1.0/24. Of course SIP ALG must be turn off on B210.

IP phones (192.168.2.x/24)–> VOIP switch (192.168.2.2/24) --> (LAN, 192.168.2.1/24) B210 (WAN, 192.168.1.2/24)–> (LAN, 192.168.1.1/24) Hub5 Router --> Internet --> SIP Provider

To ensure Voip traffics alway go through same WAN, please add Outbound Policy below.