Newbie, need help with Balance 20 and multi-wan + mobile set up


#1

Hi everyone,

Brand new owner of a new shiny balance 20 :slight_smile:

I’d like to trial it at a Client’s site with the following scenario:

SETUP

Wan 1 = iinet line 1 ADSL via bridged TP-Link 8817
Wan 2 = iinet line 2 ADSL via bridged TP-Link 8817
Mobile = Telstra 4G.

LOAD BALANCING

Wan 1 and Wan 2 are always on.

Mobile only comes on if both Wan 1 and Wan 2 fail. (Or if just one fails?)

Or Mobile comes on if Wan 1 and Wan 2 are saturated.

Is this possible?

PRIORITISATION

Within the Wans 1 and 2 + Mobile the priority should be:

A) Email
B) Browsing & Downloading
C) Soonr.com, which is like Dropbox.

D) Everything else.

Is this possible?

Many thanks for any help.

Best wishes, Martin


#2

Hi Martin,

I suggest use default settings for Outbound Policy with changes below:-

  1. HTTPS_Persistence Rule
  • Load Distribution: Custom
  • Load Distribution Weigh: WAN1=10, WAN2=10, Others = 0
  1. Default Rule
    Default Rule: Custom
    Algorithm: Overflow
    Overflow Order: 1)WAN1, 2)WAN2 3)Mobile Internet

Please configure this via Network > Qos > Application > Application.

Hope this help.


#3

Outbound Policy like attached screenshot?

Do I have to have the Mobile Internet “Always-on” for this to work?

I currently have it on “Backup Priority”

Thanks very much for your help, Best wishes, Martin


#4

Hello,

You will need have the mobile connection “Always On” for the Overflow rule to work properly :slight_smile:


#5

Thank you Jarid :slight_smile:


#6

Hi TK,

I’ve had the time to test this on my own connection and it doesn’t seem to work.

My Test Setup:

WAN1 = iinet ADSL 2

Mobile Internet = Telstra 4G.

No WAN2.

Settings as above, with Mobile Always on.

Currently my WAN1 is shaped to 256/256 kbps.

I test using speedtest.net in Firefox and I use all the bandwidth I’ve got on WAN1.

I then download a 50MB file in a different browser and the Mobile Internet does NOT kick in.

It just slows down WAN1 even more.

Help!

Regards, Martin


#7

Hi Martin,

Base on the description, the new connections should flow using mobile WAN if WAN1 is congested. Can you please redefine your test case by make sure the WAN1 is congested ? Beside that, possible to let us know what network protocol is used when downloading the 50MB file? (HTTPS or HTTP)

If you still having issue for the outbound policy, please open a support ticket here

Thank You


#8

Hi sitloongs,

I’ve submitted a ticket (Ticket #753146) to support.

In answer to your question:

Wan1 is saturated with Spotify through Sonos as Wan1 is throttled to 256kbps by the isp as I have reached my monthly quota.

I then open a different browser and try and download a 50MB file through a http site.

It just gets added to Wan1 instead of going to Mobile Internet.

Regards, Martin


#9

My understanding is that the rules for overflow only work based off of the WAN settings. So if your connection is normally 512kbps and it is set up that way in the router, then the router won’t apply overflow rules until it reaches 512kbps. The router doesn’t know your ISP has throttled your connection to 256kbps and so it won’t switch to another WAN. I’m curious to know if I am wrong here.


#10

Your understanding is correct. In order for the overflow algorithm to work correctly the correct up/down speed settings on the WAN setup page need to match what the carrier is providing.


#11

Hi cyclops,

You’re definitely on to something there :slight_smile:

I entered the throttling speeds into WAN1, ie 256/256 kbps and initially it seemed to work.

Wan 1 has mostly Spotify.

Mobile should then kick in when I download a 100MB file from http://www.thinkbroadband.com/download.html

However the 100MB file just gets added to WAN1 and floods the connection, stopping Spotify.

See image below.



#12

Hi Martin,

Two issues that we need to take consideration here:

  1. WAN “Upload & Download” Bandwidth can’t be dynamically/automatically defined base on the available bandwidth when ISP perform throttling (Quota limit reached)

  2. Connections will still be forwarded using ADSL (WAN1 & WAN2 connections) when the throttled WAN usage is low.

Please consider to enable “Bandwidth Allowance Monitor Setting” for the ADSL connections. You can get notified when usage hits 75%/95% of monthly allowance by enabling Email Notification & disconnect the ADSL WAN when usage hits 100% of monthly allowance.

With this setting, you can make sure that the ADSL WANs will not being used when quota limits reach to avoid the above mention issues.

For more information regrading to the Bandwidth Allowance Monitor Setting, please refer to the attached screenshot


Thank You


#13

Hi sitloongs,

I’m not concerned with quotas normally.

What I want is the Mobile Wan to kick in when the Wan1 is saturated.

This is called overflow.

I’ve set Wan1 to what the connection is now, 256/256 kbps.

It shouldn’t matter what the actual speeds are, ie 20/20 Mbps, if that link is saturated then Overflow should kick in.


#14

Hi Martin,

Base on the earlier post, you are concerned on the ISP throttling when WAN Quota limit reached.

I believe you miss understood the usage for overflow algorithm.

Overflow - Traffic will be routed through the healthy WAN connection that has the highest priority and is not in full load. When this connection gets saturated, new sessions will be routed to the next healthy WAN connection that is not in full load.

Please understand the saturated word correctly for the above statement:

Example:
WAN1: 256kbps up/256kbps down (Available Bandwidth)
Mobile USB: X up /X down

Saturated mean if WAN 1 is utilized 85%-95% for the available bandwidth then the new connections will start to forward using mobile USB. If the WAN1 utilization when below 85% then new connections will forward back using the WAN1 link.

For your case, the saturation is on ISP level, thus the overflow algorithm will not help detect such saturation.

Thank You


#15

Hi sitloongs,

No, I am not concerned with WAN Quota or ISP throttling.

Please forget about throttling and assume I have a 256/256 kbps WAN1 connection.

Those are the speeds I have entered into Wan1.

Those are the speeds I’m actually getting.

Now, to use your words:

“Overflow - Traffic will be routed through the healthy WAN connection that has the highest priority and is not in full load. When this connection gets saturated, new sessions will be routed to the next healthy WAN connection that is not in full load.”

WAN1 is now saturated, new sessions are NOT being passed to the next healthy WAN, ie Mobile Internet.

Regards, Martin


#16

Hi Martin,

Do note that when you defining the WAN download/upload speeds this will bandwidth limit the available upload speed for the WAN to 256kb. Thus when you perform speedtest using WAN1, you will only get 256kb upload speeds.

Let’s follow up using using support ticket , as this will allow us to have better channel to diagnosing the issue.

Thank You

Thank you


#17

Update emailed to Support this morning, thanks.


#18

I’ve now got this running on the Client Test Site using the following settings:

  1. HTTPS_Persistence Rule
  • Load Distribution: Custom
  • Load Distribution Weigh: WAN1=10, WAN2=10, Others = 0
  1. Default Rule
    Default Rule: Custom
    Algorithm: Overflow
    Overflow Order: 1)WAN1, 2)WAN2 3)Mobile Internet

I’d like to get the traffic flowing evenly over Wan 1 and Wan 2 if possible.

At the moment most traffic goes over Wan 1.

Would it be possible to add an Outbound Policy before the Default overflow policy?

ie Weighted Balance Wan 1 and 2 = 10, Mobile = 0?

To re-iterate, I’d like to achieve the following:

"Wan 1 and Wan 2 are always on.

Mobile only comes on if both Wan 1 and Wan 2 fail. (Or if just one fails?)

Or Mobile comes on if Wan 1 and Wan 2 are saturated."

Thanks, Martin