New Surf Soho Vlan Setup Issue

Hi @,

I have taken the plunge and purchased a Surf Soho MK3 firmware version is 7.1.2 build 1387, unfortunately I am stuck at trying to create a vlan, when trying to enable vlan by clicking on the white question mark in the blue circle, as you can see from the screen print below ( have changed ip and port number just to be safe) there is no mention of vlans. I did a factory reset on the router and tried again with no success, appreciate if someone could point me in the right direction…Thanks

Hi Donald - Welcome to the forum! :slight_smile:
You’re clicking the wrong help / question mark icon. The one you’ve found there is add a new IP address, you want to add a VLAN.
I don’t have a SOHO here to check but I suspect it will be the one in line with the ‘Network Settings’ section header.

1 Like

Also, upgrade to firmware 8.0. It has bug fixes and new features and things.


Hi Martin thanks for the welcome, I appreciate you taking the time to reply, I took your advice and updated the firmware to 8 but still cannot find the correct question mark icon to add a VLAN.
Does it make any difference that I have not connected the router to the internet yet?
I have reset my SOHO twice now with no success, know it has to be something simple I am missing.
These are the steps I’m taking clicking on the following.
Network Settings
Untagged Lan
IP Address click on white question mark (configure additional lan)
The question mark in line with Network Settings is to configure Pepvpn.

Hello Donald,

VLAN should be enabled by default on both 7.1.2 and 8.0. The Network Settings screen should look something like this since you’ve factory defaulted the unit. You may not see the 'This configuration is being managed by InControl" if you do not have the device in IC2.

If you are not seeing this screen I would recommend opening up a ticket for us to look at the device. You can open a ticket with us here.

1 Like

Hi Zach thanks for your feedback doh! as stated VLAN is enabled by default, all good now, just need to get my head around firewall rules now.