New PepLink Balance 20 not working


#1

Hooking up the cables and power to my new PepLink Balance 20 doesn’t seem to be enough to get a connection to the Internet working. Not sure what I’m missing or where to start with diagnosing the problem.

At this point my setup is as simple as can be. I have a single WAN connection connection plugged into the WAN1 port. My PC is plugged directly into one of the LAN ports.

My ISP is a line-of-sight wireless provider. I have a directional antenna on the roof and a little powered box (called a Point-of-Entry) with an Ethernet connection and little else.

I plan to add a second WAN connection in a few weeks, but want to get this working first. Right now, I realize I’m using it as a very expensive hub and I’m failing at that.

Connecting my computer directly to the ISP point of entry works fine and seems to configure itself using DHCP. I’ve tested all of the cables and tried two different computers.

I have tried power cycling everything in various orders (except my computer to be honest, maybe I’ll try that too.)

The default configuration for the WAN1 port seems to be DHCP, so I don’t think I should need to do anything special to make it work. I tried the setup wizard to no avail. In the admin UI, the status of the WAN1 connection is “Connecting…” It never passes that point and seems to be hung.

Should this just work? Any idea what to try next?


#2

I hooked my computer back up to it to see if rebooting it would help, but didn’t get as far as rebooting before I noticed that the Internet is working. I had to double check everything to verify I was actually using the balance. Now it is connected and happily chugging away.

Any explanation for this self-healing would be appreciated so I don’t spend two hours messing with it again. Do I just need to wait 5-10 minutes or so before declaring a problem?


#3

The WAN interface will take some time to negotiate the connection but usually it should be up and connected within a minute.

You may try to reboot the Balance 20 and see if you still encounter the same problem.