Mysterious dual WAN fail on https port forward

Problem: WAN2 interface port forwarding appears to fail when WAN1 is connected, works when WAN1 is disconnected - Why?

I’ve been using our Peplink Balance 30 v2 since 2012 in a Dual WAN configuration (super reliable - love it), I’ve had a web site configured in the private IP space of the LAN and an Inbound port forwarding mapping that takes access at port 443 on either of the WAN IPs and forwards it into port 443 in the LAN. Worked great for years, changed providers, updated the Inbound port forwarding, etc. Always worked. Final configuration was WAN1-~ADSL, WAN2-Cable DOCSIS3.0

Moved to a new location, new building, new ISP equipment. First established a one WAN (ATT) link and the Inbound port forwarding works great. Website access through WAN1 IP is good enough. Weeks later, established a second WAN (DOCSIS 3.1 Cable based) link. Test the Website access through the WAN2 IP - nothing - no response. Outbound access through WAN2 works. Maybe Cable ISP is blocking 443? No, Wiresharking the WAN2 interface proves port 443 requests are coming through on WAN2 Interface. Disconnect WAN1 and suddenly WAN2 website access is working fine. Re-enable WAN1 and WAN1 website access works but https requests to WAN2 get no response.

I do have an HTTPS persistence rule in the outbound Policy, which I had before. (Disabling it does not change the behavior) Unfortunately I’ve changed the Firmware to 8.0.1 (from 7.x) so this may have created a complication but I’m at a loss for ideas on what has gone wrong. I do not have anything complicated, and almost the same setup as before, so what have I missed?


This is more like troubleshooting case, please open a support ticket for support team to help verify on this.

1 Like