Max Transit Duo LTE-A Constantly crashes - AP Flaky at best

I have had my Transit Duo LTE-A for about 8 weeks now and am having problems with it constantly crashing, or SSIDs not being visible, even though the AP reports it is up.

So I have it setup with 2x LTE SIMS (Verizon & Cricket), and usually connect to Marina or hotel wifi using WiFi WAN on both 2.4 and 5 GHZ. I have the inbuilt AP setup with 3x SSIDs. XXX-Dual, XXX-2G and XXX-5G.

One minute all 2 SSIDs are there, sometimes only the 5G and Dual are visible (seems to coincide with WiFi WAN on 2G Connecting) Other times only 2G is visible, sometimes neither is visible, but I can usually connect to the router via ethernet cable - or via remote web from InControl.
At other times it appears to re-boot spontaneously for no reason. Nothing in the event logs to indicate why.
I have tried the latest 8.1 firmware, the beta firmware and a previous 8.0.2 firmware.
I have tried deleting my speed fusion profiles and outbound policy stuff.
I have even done a factory reset and the just configured the basics, but it still crashes.

Any advice what to do next.

eg.

Dec 03 18:02:56 Admin: admin (192.168.50.10) login successful
Dec 03 18:02:54 WAN: Wi-Fi WAN on 5 GHz connected to Zencity (192.168.1.146)
Dec 03 18:02:51 System: Time synchronization successful
Dec 03 18:02:28 System: Time synchronization successful (InControl)
Dec 03 18:02:27 WAN: Cricket connected to cricket (10.51.221.72) in SIM slot A
Dec 03 18:02:22 WAN: Verizon connected to Verizon (100.101.69.231) in SIM slot A
Dec 03 18:02:05 System: Wi-Fi AP Normal Mode
Dec 03 18:01:38 System: Started up (8.0.2 build 4407)
Dec 03 17:59:58 System: Started up (8.0.2 build 4407)
Dec 03 17:51:05 System: Started up (8.0.2 build 4407)
Dec 03 17:43:12 System: Started up (8.0.2 build 4407)
Dec 03 17:38:20 System: Started up (8.0.2 build 4407)
Dec 03 17:36:56 System: Started up (8.0.2 build 4407)
Dec 03 17:34:58 System: Started up (8.0.2 build 4407)
Dec 03 17:33:14 System: Started up (8.0.2 build 4407)

Why did it reboot 8 times in half an hour?

I had very similar issues, but it’s been stable for a few days now… SSIDs would just stop working, but the LAN port would be fine.
They have me running the Beta 8.1.1 firmware at the moment

For maximum stability, it seems that AP and WiFi-WAN should not be combined on the same device.

I hate to suggest more hardware, but if you want more stability you should consider a stand-alone AP.

What is the power source? Any chance power issues?

Yes, seeing exactly that… after a few good days, it’s doing it again. SSIDs just disappear. WiFi WAN is working OK.

I was having some poor client -> AP connections. Although my Laptop (Macbook pro) was showing good strength. the AP was reporting -80dBm. So I tried clicking the boost, and at the same time set the Client Signal Strength threshold to “5” (-90dNm). When I hit apply the SSIDs disappeared and I can’t get them back. The AP thinks they are working, but multiple devices can’t see them. (Android phone, iPad Pro, Macbook)

Maybe I try the beta firmware.

@erickufrin Yes, or I should perhaps just keep the rule that I only ever use 5GHz for LAN and 2.4GHz for WAN (or vice-versa)… but that’s a bit disappointing.

Mostly use the 110v powerpack that came with the device, but have also tried the 2xMicro USB connections both via a portable battery and via a large 12V batter bank on a boat. I have noticed the device being warm, but not too hot.
I am suspecting it drops the AP while negotiating the WiFi WAN connections (changing channels if it needs to and negotiating other auto-parameters), but then can’t or won’t bring the AP back online for some reason. Perhaps some setting on the AP conflicting with the Remote WAN WiFi settings (Eg. Channel width) ?

I believe your theories on why it drops are correct. It sounds like power is solid.

@JamieS, please upgrade your MAX Transit to 8.1.1.

Have you connected the WIFI antenna to the MAX transit? Ideally, WIFI client should get -70dBm and above, -80dBm considers a poor WIFI connection.

1 Like

@TK_Liew thanks… yes have updated to 8.1.1 (5025). Have the Max moved to within 10ft of the cable modem -27dBm. (Was previously testing from the next room around -60dBm). Have a 7-in-1 antenna, but have also tried with default antennas shipped with the device.

Using WAN as Priority 1 and Cellular 1 & 2 as priority 3. I can see both SSIDs.
I then move “WiFi WAN on 2.4 GHz” from “disabled” to Priority 2 and a few seconds later the XXX-2G SSID disappears and the WiFi WAN connects (in Standby). I move it back to disabled and the SSID re-appears.
Same thing happens if I do it with “WiFi WAN on 5 GHz”. XXX-5G disappears.
No meaningful messages in the Event Log or the AP Event Log. Aside from…

Dec 15 12:29:30 XXXX-XXXX-XXXX: Transmit Power changed from 9dBm to 15dBm
or
Dec 15 12:30:36 WAN: Wi-Fi WAN on 2.4 GHz connected to 8F8635 (192.168.0.7)

@TK_Liew - Happy to give you remote access to the device if you like. (Or send the diagnostic report file)
(I’m in US Central TZ)

@JamieS, I think you can provide those details via a support ticket (https://ticket.peplink.com/ticket/new/public) if you have not submitted one, our team (and/or @TK_Liew ) will follow up from there.

I have masked out the S/N in your previous response for a security reason.

1 Like

For those interested in following this… here is my latest comment on the support ticket…

I have been watching this for some time, trying to work it out, and I think I understand where the problem is:

If you manually set the channel and bandwidth of the AP to match the WiFi WAN, then all is OK. The problem comes when the AP settings do not match the WiFi WAN settings. When the AP is set to “Auto” on either channel or bandwidth, it may choose different settings to the WiFi WAN, and when this happens, it shuts down the AP. Occasionally it does choose the same settings and all works OK.

However the issue here is that when APs are set to auto, it is common for them to periodically scan the spectrum and shift to the quietest channel. When the upstream AP does this, the WifI WAN must also shift channels. If the Pepwave AP is set to manual channel/bandwidth. it shuts down. If it is set to auto, it may occasionally choose the same channel and bandwidth as the WiFi WAN, but usually it does not and it shuts down.

The issue here is that the algorithm to decide the channel looks at channel usage and nearby APs. When the Pepwave AP is broadcasting on the same channel as the WiFi WAN (and hence also the same channel as the upstream AP) - the Upstream AP is likely to want to change channels to avoid congestion (particularly if the Pepwave router is close to the upstream router, has a high-gain antenna, and/or has boost enabled)- which in turn triggers the WiFi WAN to move channels and the the Pepwave AP to either move also, or shutdown due to a mismatch in settings.

SO… one possible solution is to disable manual setting of Pepwave AP radio parameters when WiFi WAN is active - and force the AP to use the same settings as WiFi WAN. This will ensure the AP stays up after a channel switch.

3 Likes

I had the exact same issue, and its super nice to know why :slight_smile:

I ended up using an external AP.

Thanks for writing.