Max Transit 5G Issues

I have some issues with my new 5G unit.

I have a T-Mobil SIM installed but it will only install with Firmware ver. 8.1.1 I tried to install ver. 8.1.2 but it looses the SIM information and will not repopulated it so I rebooted to the older firmware and the SIM information is there.

I have no way to change cellular bands to pick the one I want. There does not appear to be anyway to do a manual selection like the manual states.

I keep getting repeated DNS failure problems on a local Wifi system that I can easily connect to with my table, PC or phone but the Max tries and fails with the DNS failure message.

I am very new to all this so I may have something set wrong.

Thank you. I tried to load that one and the Firmware upgrade page stalls at 79%. The unit did not complete the upgrade on the screen but when I reconnected to the unit in the Admin area it shows Firmware 8.1.2 now. How do I know it actually upgraded to the 8.1.2s011 version?

Never mind. I see the firmware has been updated on the bottom of the Dashboard.

Still not able to change cellular bands manually. It is connected to n71 which is at least a good 5g band.