MAX HD2 Status LED Red


I ordered 2 of these MAX HD2 units as a trial for an oil and gas application. The first unit was tested, worked well and deployed.

Six months later, I am now trying to test and deploy the second unit however I am unable to get the device to do anything. As soon as it powers on via POE the red LED is illuminated and stays on solid. With the VERY limited information available on this device from Peplink, it seems to indicate the unit is “Booting up or Busy” however the light does not change to green.

It is also not possible to connect to the device.

Any advice?

Thank you.

Good Afternoon
Can you try powering it with the PSU supplied with the unit rather than via PoE?
It could be the device is not getting enough power to boot up properly.

1 Like

The unit did not come from the vendor with a power supply – nor antennas.

The PoE is 48v @ 1.25AMPs (56Watts Max @ the Port). Is this not enough power for the unit? What is the requirement?

Additionally I have tried powering it from our Cisco SG500 with 365+W capacity and our Fortiswitch at similar capacity with the same issue.


Please open a support ticket and get support team to assist on this.

1 Like

Did you get a response and a solution to this issue?