Lower internet speed with firmware 8.1.0?

I have a Pepwave Surf Soho Mk 3. My ISP generally provides consistent modem/ethernet speeds of 150 Mbps, and of course the throughput is limited to about 120 Mbps. Usually I get around 110-120 Mbps for the ethernet connection to my desktop, directly from the router into the desktop.

In September, I upgraded the firmware to 8.1.0. I also noticed around the same time that my desktop internet speeds are around 38 Mbps, a significant drop from the 100’s. Interestingly, wifi speeds off of the same router seem consistently in the 60’s or 70’s Mbps.

I have “rebooted” the modem etc., and have also tried a different ethernet cord connection, and currently have an appointment with the ISP to come out and take a look. I suspect the issue is with the ISP, and NOT the Pepwave router.

Nonetheless, and however unlikely, is there a possibility that some sort of issues with the new 8.1.0 firmware may somehow be the cause of the problem? Or moving the WPA security settings from WPA2 to WPA2/WPA3? Those are about the only changes made to the overall system that I’m aware of, at least on my end.

The ISP often tries to convince me to switch to their combined modem/router combos or the like. I prefer the security of using the Pepwave router separately from the modem, and would like to be a bit more informed before dealing with the ISP visit.

Any thoughts are appreciated.


Have you re-learned the network after switching to WPA3? I had disconnect issues with the change to WPA3 until I clicked “forget this network” on all my devices and relearned it with the new security.

1 Like

I suggest rebooting back to whatever firmware you were using prior to 8.1 and seeing what effect that has. What firmware were you using before 8.1?

Also, have you done speed tests while directly connected to the modem?

As for WPA3, the software is new and thus best avoided for a while. And, I don’t see where it brings much benefit security wise. A long password with WPA2-AES is plenty secure.

1 Like

Thanks for the suggestion. However, I may have discovered something else. (See response to Michael1234).

Thanks for the suggestion/reminder to directly connect to the modem. When I did so, I got speeds well in excess of 150 Mbps. So here’s the strange part: after doing that, I then set things up again as before – modem to router to desktop – and now, I get expected speeds approaching the 120 Mbps throughput of the router! Wifi is a bit faster, too. So the problem seems fixed.

Would you have any ideas about what could explain this? Before I made the temporary modem connected directly to desktop trial, everything seemed seated in the ports correctly, and there seemed to be no problems with the cables (indeed I’m now re-using the same cables). I would note that during the temporary modem direct to computer interlude, I utilized a completely different cable; and then upon re-connecting everything as before [modem to router to desktop], I used the same cables as before and now there is no issue.

So during the interlude of modem direct to desktop, modem/ethernet port was in a detached/disabled state for a time. Was my problem potentially caused by static or dust particles or the like that coincidentally self-corrected as a result of the modem-direct-to desktop interlude? All of this feels like the proverbial smacking of the TV set to correct a problem. A mystery. I will have to test over the next few days to see if it remains corrected.

SPOKE TO SOON. Within about an hour, problem arose again with slow speeds. Same process, results once again with the problem seemingly “solved.” For some reason, I seem to be getting consistent speeds from my modem, but when sent through the router it’s dropping. I’m going to try to get some new ethernet cables to see if that solves the problem, but I’m beginning to wonder if there’s something wrong on the hardware front with my Pepwave?

It certainly could be flaky cables. Look in the support.cgi web page for any Ethernet errors.

Is cpu usage high during a speed test? Afterwards? I tested at fast.com on wifi and cpu maxed out at 86% when I had the LAN to myself

And, again, reboot to the prior firmware, whatever you were using before 8.1.

And, it could also be your ISP. At busy times of day, speeds go down on shared pipes. Thus, its best to test very early or very late.

Problem is still here. Slow ethernet Surf Soho Mk 3 when printer is on?