Local DNS on SOHO MK3

#1

I would like to resolve a custom hostname to a local IP address.

I’ve tried adding the following to Local DNS Records under Network->LAN->DNS Proxy Settings:
Host name: serve.local
IP address: 10.32.20.101

However, ping on a connected host does not resolve the IP address.

In case it matters: under WAN connection settings I have assigned 1.1.1.1 to DNS Server 1, and 1.0.0.1 to DNS Server 2 and unchecked “Obtain DNS server address automatically”.

Many thanks,
Bernhard

0 Likes

#2

@ttmetro

You need to make sure the client devices is using SOHO MK3 LAN IP as DNS server in-order the Local DNS Records to work.

1 Like

#3

Thank you for the response! Unfortunately I do not seem to be setting the DNS server correctly.

I tried setting the DNS server on the LAN (specifically a VLAN) side to the router address on this VLAN, specified in Network->LAN->IP
Server 1: 10.95.10.7
Server 2: 1.1.1.1

On the WAN side I left them at
1.1.1.1
1.0.0.1

However, the name is still not resolved (from a computer with IP 10.95.10.101).

Help is most appreciated!
Bernhard

0 Likes

#4

I am having the same problem
local DNS records are not resolving at all, whether the entry specifies an internal ip on the LAN or a known external ip address

0 Likes

#5

Did anyone get this working? An example would be VERY MUCH appreciated!

I could not find the information I need to set this up in the manual.

0 Likes

#6

Just do a quick check for the local DNS records and it should work as expected.

Defined record:
image

DNS resolve test:
image

Would you able to share your configuration & test results ?

1 Like

#7

It does not work for me (test and configuration are below):

0 Likes

#8

Can you check with nslookup and specifying the router address in the command line: nslookup serve.local 10.95.10.7

When you use nslookup with specifying the router address, you should see under Server and Address which dns server is exactly used. If this is not the router’s address, you will have to configure your network settings to use your Soho MK3 as DNS server.

(in this example, the router is on address 192.168.5.1)

image

1 Like

#9

NOTE: this is an osx issue - change .local to .home, then everything works fine. See next message.

nslookup works fine, but ping does not.

The browser (I use chrome) cannot resolve serve.local, nor can tools lik ssh.

1 Like

#10

Figured it out:

This is a max (osx) issue. For some reasons, osx has difficulty with the .local domain. Changing to “serve.home” - everything works as expected!

Many thanks and sorry for accusing the router, which is not to blame.

2 Likes

#11

Glad it got resolved. Now that you mention, i probably have seen that issue passing by some time ago.

1 Like

#12

Hello @ttmetro,
You most likely found this on Apple’s support site at https://support.apple.com/en-au/HT201275 with how to use “.local” and we are sharing it here for reference if others also come across this issue.

Mac OS X v10.4

In Mac OS X v10.4, all host names that end in “.local” are resolved using Multicast DNS (Bonjour) by default. To use Unicast DNS to look up “.local” names, add local to the list of search domains in the Network pane of System Preferences. Select the desired network interface and click Configure. Add local to the Search Domains field. If you have multiple entries in this field, be sure that local is first, and separate them with commas. For example:

local, apple.com

Happy to Help,
Marcus :slight_smile:

2 Likes