Issue with firmware 6.3.0, Surf SOHO, HW ver 2


#1

I have upgraded two Balance devices and two Surf SOHOs with the new firmware, 6.3.0, build 1967. Three of the four work excellently (as expected from Peplink). However, one is a problem …

The upgrade to the “problem” SOHO seemed to go smoothly however two of the three devices on the LAN side of the router have no connectivity. They are not seen on Status|Client List and I can’t reach them from the WAN side. On the LAN side (192.168.x.x) there is one Windoze 10 computer and two M2M devices. The Windoze machine is fine with 6.3.0; the M2M devices can’t be contacted until the SOHO is rebooted using 6.2.2 (which works perfectly).

While I’d like to power cycle the M2M devices as an experiment, that’d be difficult as they are many miles away (and I don’t think I should have to rely on that approach anyway.)

Any thoughts as to what is going on?

(Side note to Peplink: Thanks for permitting boots from either of two installed firmware versions – that feature saved me a real mess as reversion to the earlier version was trivial!)

Rick


#2

Hello Rick,

I have just PM’ed you with a fix that should address the issue. If it does not feel free to reply back and we can take a closer look.


#3

Jarid, I am having a similar problem with my Surf SOHO. Could you provide the fix to me as well?


#4

Hello @oakhursttech,

I have just PM’ed you with the special firmware. As well, if it does not work feel free to reply back and we’ll take a closer look.


#5

Hi Jarid,

I believe I had the same experience. I posted about it over here: https://forum.peplink.com/threads/5895-Surf-Soho-issues-with-6-3-GA

Will you send me the secret fix?

Thanks


#6

Hello Cyclops,

I have just PM’ed you with the special firmware.


#7

Similar issue here. Some devices on the LAN won’t connect using the 6.3.0 firmware, including a Roku (that was mentioned by another user coincidentally). May I have the secret fix too?


#8

The “special” firmware did not work for me. I’m back on 6.2.2.


#9

Hi,

Would you please open a support ticket here for us to further check on the issue.

Thank You


#10

Same with me. I was told they are working on a fix.


#11

Hi all,

For those having LAN connectivity problem with Surf Soho Hw2 v6.3.0, please upgrade to this firmware - http://download.peplink.com/firmware/soho/fw-surf_soho-6.3.0s013-build1986.bin. Below is the symptom of this problem:-

  • Affected for the non-Windows machine.
  • Affected for Surf Soho Hw2 with v6.3.0 only.
  • Affected for the device that connected to Surf Soho Hw2 LAN ports only.

If you still facing problem after upgraded to v6.3.0s013, please open ticket for us to take closer look.

Thank you.


#12

Tried 6.3.0 build 1986. Most of my windows and non-windows devices work fine, except Apple TV and iPhone won’t connect properly. Going back to 6.2.2 which works fine. Maybe I’ll do a ticket, or just wait for this firmware to get through customer-beta testing first.


#13

Hi,

The reported issue only affected for the device that connected to Surf Soho Hw2 LAN ports only. Seem you mention Apple TV and IPhone, are the devices direct connect to the Surf Soho using Ethernet connection ? Else this may not related to reported issue.

Can you describe more for the Apple TV & Iphone connection issue ?

Thank You


#14

The Apple TV is hardwire-connected to the LAN port (via a network switch). The iPhone is connecting via WiFi to a separate Netgear WiFi access point (not to the Peplink router’s access point as I have that shut off), and then hardwired from the Netgear AP to the Peplink router LAN port. So effectively, both Apple devices are connected to the Peplink router via the LAN ports. The iPhone ‘says’ it connects to the network, but there is no functionality once connected. The Apple TV doesn’t work either. I noticed the Peplink router is assigning the Apple TV an IP of 192.168.0.101 and the iPhone to 192.168.0.102, which are out of the router’s DHCP range (192.168.1.2 - 192.168.1.14). I noticed the iPhone itself, set to DHCP mode, shows the router is IP 192.168.0.254, even though the router is actually 192.168.1.1. I tried assigning a static IP for the iPhone in both the router and the iPhone, but no luck. Possibly some sort of IP assignment problem specific to Apple products? Note that firmware 6.2.2 build 1790 works fine with all my devices, including Apple, and it gives the Apple devices proper IP addresses. I submitted a ticket w/ most of these details and a couple Diagnostic reports for each of the firmware versions. Thanks.


#15

Hi,

  • How many Vlan you have defined in Surf Soho? 192.168.0.x is the IP subnet for one of the Vlan?

  • Have you enabled DHCP server in Netgear AP?

  • Do you mean you have 2 routers (including Surf Soho) in your LAN environment and configure IP reservation for iPhone?

  • What IP, subnet, gateway and DNS server you statically assigned to iPhone?


#16

TK Liew,

  1. I only have one Vlan defined (didn’t even think you could do multiple Vlans in this router, I’m running 6.2.2 at the moment). Maybe that’s a new feature in 6.3.0? But I never tried configured Vlans.
  2. DHCP is not enabled in the Netgear AP.
  3. I only have one router in the LAN environment, the Surf Soho. When I said I assigned a static IP in both the iPhone and the router, I meant I tried it once in the Surf Soho router and once in the iPhone itself in the WiFi settings (there’s a spot where you can assign a static IP in the iPhone). But when none of this worked, I went back to a router-assigned IP, still with no luck.
  4. When I tried putting static information in the iPhone, I used IP 192.168.1.65, Subnet Mask 255.255.255.0, Router/gateway 192.168.1.1, and left DNS blank.

#17

Build 1986 fixed it for me on all three of my Surf SOHOs.


#18

Hi,

  1. Do you have another DHCP server on LAN environment?

  2. Possible to track the MAC Address for 192.168.0.254? If so, MAC address same with Surf Soho LAN Mac address (Status > Device)?

  3. If you not able to track MAC address for 192.168.0.254, please do me favor below and open ticket to submit the required documents for us to investigate:-
    3.1 Login to Surf Soho > Enter http://192.168.1.1/cgi-bin/MANGA/support.cgi.
    3.2 Navigate to Network Capture > Click Start. Please do it on non-peak hours.
    3.3 Reproduce the problem (Associate iPhone to Netgear AP and ensure it grabbed IP 192.168.0.x).
    3.4 On the same support.cgi page, Network Capture > Click Stop > Download.
    3.5 On the same support.cgi page, Download Diagnostics Report.
    3.6 Submit documents in step 3.4 and 3.5 via ticket.
    3.7 Do let tech support know the MAC address and IP for iPhone you tested on step 3.3.

Thank you.


#19

Hi all,

For those experienced with firmware having an expiry date (after upgrade to v6.3.0s013), please help to load this firmware into your Surf Soho - http://download.peplink.com/firmware/soho/fw-surf_soho-6.3.0s013-build1996.bin.

Thank you.


#20

I spoke too soon. My Samsung Smart TV cannot pull an IP address from the Surf’s DHCP server with firmware 6.3.3 build 1987. As soon as I rebooted with firmware 6.2.2 it started working again. I think I’m done with version 6.3. It has way too many issues. I’m waiting for 6.4.