Issue with AP One Rugged 3.6.0-1805 Firmware and second port

I’ve just upgraded from 3.5.4 build 1681 to 3.6.0 build 1805 and it has caused a major problem. Booting from 3.5.4 makes it go away with no other changes, so I’m stumped.

My WAN IP address is 192.168.168.50/24. It sits on my home network, and has another device plugged directly into the second port which is on 192.168.168.51.

The AP mode is set at Router / IP Forwarding although the behavior (as far as my use) is exactly the same if set to Router / NAT.

The LAN (wireless) side address is 192.168.169.50. LAN Gateway is the same. DNS1 is set to 192.168.168.1, which is the router on the home network.

A DHCP Range is set at 192.168.169.102 - 192.168.169.200.
A hardwired static IP with a MAC address sits on 102.168.169.101.

This is set because the AP One Rugged gets disconnected from the home network, but needs to connect and feed DHCP addresses to tablets and iPads that must access the second Ethernet port on 192.168.168.51.

Here s my problem.

When connected under 3.6.0, the tablets on the 169 network can connect to the internet and to the 168 network, but not to the 192.168.168.51 device on the second port of the AP One Rugged. They CAN connect to the AP One Rugged itself (192.168.168.50).

Similarly, devices on the 168 network can connect to the AP One Rugged on .50, but they cannot connect to or ping the device on the second port.

If I boot from the 3.5.4 firmware all is well. It is as if the 3.6.0 firmware is ignoring the second port.

Is this just a bug, or is there a configuration setting I’m missing relating to 3.6.0?

Thanks,
Tom Podnar

We will prepare a special firmware for you to address the issue. Please stay tune.

Thanks,
Gary

1 Like

Thank you, Gary. I’ll look forward to it.
Tom

On previous firmware, the second ethernet port is acting as a switch port on WAN under Router mode. On 3.6.0, we have changed the second ethernet port to a LAN port under Router mode.

To address the issue you are facing, we have added an option on the UI to change it back to a switch port on WAN.

https://download.peplink.com/firmware/apone/fw-ap-acmini_enterprise_flexhw2_rugged-3.6.0s2-build1808.bin

After you have upgraded your AP to 3.6.0s2, navigate to Network -> WAN on UI. You will find a new option “Ethernet Ports” with option “WAN/LAN” selected. Please change it to “WAN”, save and apply.

Thanks,
Gary

1 Like

Gary. Now I understand the problem. Your solution is brilliant, and will definitely add flexibility to the device. Thank you for the quick work.

I am a huge fan of the AP One Rugged. Its performance since the day I got it has been outstanding.

Regards, and thanks,
Tom

2 Likes

4 posts were split to a new topic: AP One Rugged - Firmware