iPad VPN + RDP doesn't work


#1

I’m having a problem using an iPad to connect by L2TP with IPsec VPN (Balance One firmware 7.0.1 build 2988) and then use the Microsoft RDP client app to access a desktop machine.

The VPN connects fine. However, RDP simply doesn’t work anymore. This used to work fine. I’m not sure when the setup stopped working as it’s only occasionally used by the client.

However, if I’m on a PepVPN network wifi I can use RDP to connect to the machine in question.

Does this sound like a Peplink issue or perhaps a antivirus/intrusion software gone bad? I tried disabling the antivirus/intrusion software, connecting via VPN and testing but without any luck.


#2

Is “Send Alll Traffic” clicked on?


#3

Yes. For giggles I tried with it turned off, too. No luck.

FWIW I can connect to the Peplink Balance One VPN and watch from Client List page the traffic. I just used safari and did a speed test. All fine. However, when I’m trying to connect using RDP there is no traffic coming from the VPN connection.


#4

Also: why would PepVPN + RDP work fine, but L2TP VPN on iPad not allow RDP?


#5

OK, so I went ahead and did the firmware update to 7.0.2 build 3155, and it’s working for me now.

Will test again this evening.

I would have tried the firmware update earlier if I had seen anything in the release notes about VPN or RDP, but happy it appears to be resolved…


#6

Confirmed working. This is no longer an issue.

If anyone encounters this problem in the future I recommend first rebooting their Balance One and then attempting L2TP + RDP on the ipad. I didn’t attempt a reboot of the Balance One first but it’s possible that was the solution. If the reboot doesn’t work then upgrading from 7.0.1 build 2988 to the latest firmware (at this time that is 7.0.2 build 3155) worked for me.