Internal modem slot of 20x capped at 100mbps?

I have a balance 20x with 8.1.1 firmware, i have two lte connections that get 90+ mbps, when i weight their connections as 5:5 or 10:10, it doesn’t matter, no speed tests will break 100mbps, (my cradlepoint got 220+ mbps down with round robin fwiw). The speed tests use 4 URLs for multi stream tests. This works with other hardware, as well as i am able to double my upload with the balance, but not download with peplink. i have the default and ssl persistence policy both weighted the same and starting to think there is some limitation in the code. thoughts?

The unit of measure for weighted balance is the number of sessions. If you have it set to 5:5 the first 5 sessions will go out on wan1 and the next 5 on wan2. is 4 sessions so all 4 would go out via WAN1.

Set a weighting of 1:1 instead and try again and see what happens.


ahh, ok, i’ll report back. thanks

it seems to favor the one modem, the first seems to saturate at 100, and the second one may do 10-15mbps. again, upload does in fact essentially double in speed test, but the secondary modem is not taxed like the first. i have tried several speed tests.

Is it possible the internal slot has a limitation of 100mbps? I see I can select 1000 for the flex module but only 100mbps for my internal modem

Interested to know this too, although bear in mind the internal modem is only a CAT4 module so not exactly going to set the world on fire in terms of raw theoretical speeds either.

We have a number of 20X in the field with the CAT12 modules in them and the module always seems to perform noticeably better even in areas of marginal coverage.

1 Like

I do not think that page is an indication that there is an ethernet like connection. I would posit that it is just a “standard” dropdown, and not related to interface performance.

Generally cell/IOT modems are interfaced as USB serial devices. the B20X is a LE910C4-NF module

Interfaces: • USB 2.0 HS / HSIC 150MBits download max.

Take your 20X close to the cell tower and run a straight single channel download. I have hit 150Mbits on LTE when in line of sight and < 1/2 mile from the tower with the default CAT4 modem. (band2).

i am a half mile from the tower with a roof mount panel with excellent coverage, i get 190down with a cat6 module, i can’t imagine it’s coincidence it’s maxes out at 100 every speed test. and if the interface is just there, why wouldn’t 1000mbps be a option like the flex module or other interfaces. but that wouldn’t explain why you can go above 100mbps.

can anyone else?

If I have the opportunity I will pull my B20X out and re-test at the cell tower. (remotely I only get 30-40Mbits. )

May I suggest that perhaps the issue isn’t on the WAN side, but could be on the LAN? If the connection between your speed test device and the router has some issue that would then give you the consistent “everything tops out at 100”.

I would switch down to wired 1GE directly to the b20X and put another device on another VLAN via 1GE and check that you get over 100Mbits between those two points.
One broken ethernet wire can turn a 1GE link into 100Mbits. Unplug and replug the B20X ports and the log will show what the links are negotiated at.

As for that interface speed the code is generic… every interface will have the 100&10 codes, and only if the interface has the attribute support_ge will it add the other two options. there should be a “is_ethernet” to fill out that array at all… but they didn’t do that.

	var opt_array = new Array(
		new Array("Auto", "Auto"),
		new Array("100Mbps Full Duplex", "100baseTx-FD"),
		new Array("100Mbps Half Duplex", "100baseTx-HD"),
		new Array("10Mbps Full Duplex", "10baseT-FD"),
		new Array("10Mbps Half Duplex", "10baseT-HD")
	if (support_ge)
		opt_array.splice(1, 0, new Array("1000Mbps Full Duplex", "1000baseTx-FD"));

i just tried that, as i am using a poe splitter that claims gigabit. i took that out of the mix and it still appears to have this. perhaps my tower just performs worse, i will have another module to try to see if i can isolate the issue. thanks