How to access subnet or local IP behind Mikrotik under peplink balance two?

Hi, how can i access IP behind Mikrotik under peplink balance two?
my current topology → ISP - Peplink - Mikrotik
in the mikrotik side i have NAT from peplink local IP ( (i’ve dial as dhcp client on mikrotik side)
when i remote access to peplink (via remote access user feature) i can’t ip or even gateway other local ip behind mikrotik (let say local ip
i can ping mikrotik gateway ( but can not ping other subnet in the mikrotik side.
can anyone has experience on this?

The NAT on the Mikrotik WAN is blocking you from being able to route from Peplink LAN to Mikrotik LAN.

If you disabled NAT on the Mikfrotik and add a static route to the peplink for the subnets behind the mikrotik with a destination of the Mikrotik WAN ip the Peplink has given it then you will be able to do wat you want.

1 Like

Hi i’ve try to disable NAT on mikrotik but still i can’t ping subnet behind mikrotik when connect to peplink remote user access

when i try direct connection with LAN on peplink it can ping the subnet without issue but when on remote access i can’t. I have found this thread but still can ping Remote User Access Isolation - #7 by angardi

Did you add the static routes on the peplink at the same time?

1 Like

yes already add static route, as i said before from direct LAN peplink it can ping the subnet but from remote access i can’t

OK so if you ping the LAN devices on the Mikrtik from the Peplink webui then routing is working. So you need to look at why remote user access routing is not.

Are you using openvpn for remote user access? You might need to add a static route for your mikrotik lan to use the client vpn connection…

1 Like

No, i just use the default L2TP with IPsec in Remote user Access

Throw up a network diagram and we can help you further.


i can ping subnet behind mikrotik with direct LAN to peplink but when i remote access it can’t