FusionHub on AWS - and VoIP


#1

Hi there

I have a Balance One in an OB truck and want to use Speedfusion to improve Internet reliability. We have only one truck and maybe a fly-away kit, so a second unit may be put together later. At this stage for cost reasons the centre of our Peplink network is a FusionHub instance on AWS in Sydney. Currently we are running NAT. The Balance One LAN IP range is the same as our office, so that when we are at home base, we can connect the truck LAN to the office LAN directly and offload files. The truck has a 25TB NAS and we saturate a GigE LAN for up to 12 hours for a large offload, so a direct connection is best :smiley: 10GE is on the shopping list.

A key application for us is VoIP and we use a SIP provider in New Zealand, where we are.

At the moment the ATA ( a Linksys PAP2) doesn’t want to register with the provider and no calls can be made or received.

Is NAT the best solution for our Speedfusion link ?

Is there any guidance on how to get VoIP working ? Usually we don’t have to open any ports, etc. Almost all calls are outbound.

Thanks - Richard


#2

NAT may well be playing a part in the problems that you are seeing with the device not registering. If its possible it may be worth testing by disabling the nat’d connection to the fusionhub and testing the ATA again, this way you will only be facing single NAT rather than double NAT.


#3

Thanks James - I tried that. I reduced to 2x WAN links and changed them to IP forwarding - no luck. I also tried turning NAT off in Speedfusion but that also made no difference.

I have enabled SIP/VoIP ports on EC2 in case that helps.

On the good news front - a laptop connected off the Balance (remote) back to our office over a VPN (ie Balance to Fusionhub to office) happily runs 3CX softphone, both to the office PBX as well as our external SIP provider. But I’d rather just use Speedfusion on its own. Without the office VPN it won’t connect to the SIP provider, like the ATA.


#4

Hi Richard,
I think it would be best to get this in as a support ticket, can you email support@peplink.com and we can have a look what is happening.

Thanks
James


#5

I tried a test with 2x NAT on some other routers. SIP works with 2xNAT but you only get outgoing audio on a call. Incoming audio is lost.

I tested with a Netcomm wireless NF5 in series with a D-Link DWR-922. VoIP was a Linksys PAP-2


#6

Hi,

We will followup with you using support ticket. Investigation need to be done in-order to confirm what actually happen for the incoming audio SIP traffics.

Thank You