Fusionhub LAN Connection Issue

Hello,

we setup Fusionhub on the MCR Network internal ip 192.168.210.25

We build a speedfusion Tunnel with our MaxBr2 to the MCR Fusionhub.
We can ping the 192.168.210.25 and 192.168.210.69 (SRT Server)
Outpound Policy is set on MaxBr2 for the srt encoder.
When we start the SRT Encoder (192.168.50.x) to stream to 192.168.210.69 we get a connection issue.

You see the traffic go to the tunnel but on fusionhub site it try to connect by the public ip of fusionhub and not directly in the Lan 192.168.210.0

Is there any internal route needed on fusionhub?

Does the Fusionhub have a WAN and a LAN setup or just the WAN (with the 192.168.210.25 IP).

We use the local ip in the fusionhub settings, only 1 eth is assigned.

Does it look like this then?

Then I suspect you either still have the WAN of the Fusionhub set to NAT mode (instead of IP forwarding which it sounds like you need ) or you have forgotten to uncheck ‘Apply NAT on Remote peers’ outgoing internet traffic’

If you have done those things and it still doesn’t work then you’ll need to add a static route on the SRT server so it knows to forward traffic for 192.168.50.0 via the FusionHub (192.168.210.25)

Hello,

we followed your setup.
We can ping the srt server 192.168.210.69.

I set a outpound policy to the srt encoder to speedfusion vpn tunnel for all traffic.
But we are still not able to connect the srt to port 50004.

So you can ping in both directions now right? to and from 192.168.210.69?

If so, I would likely start with network captures on each device next to find out where the traffic stops.

1 Like

Sometimes OS firewalls block traffic from unknown private subnets. Do you have your windows/linux firewall enabled?

Hello,

we did some testing internal and got following result.
The srt request is arriving on 192.168.210.69 but the answer we not go back to my max br2 router with 192.168.50.1
is there anything to set on fusionhub or is there anybody who give support on this??

I got the connection over the fusion hub to a public ip working.
I set a outbound policy for the srt encoder 192.168.50.194 all traffic to any destination via fusionhub

Could you share a network diagram showing the IPs of:

  • The fusionhub WAN
  • The fusionhub LAN
  • the IP address & gateway IP of the SRT server

It sounds like your SRT server does not have a return path to the remote subnet (192.168.50.0/24) but if you show the IP config it will make it easier to troubleshoot.