Firmware 7.0 and IPSec VPN issues


Same issue here on a balance 210 hw4. Build 2767, above, fixed the problem.


I know this thread is getting old, but I just wanted to chime in to say Build 2767 that @TK_Liew shared fixed this issue for me on the Balance One. Before trying that I had tried 7.0 (broke the site-to-site VPN from 6.3.3) and even the newer beta build of 7.0.1 (2895) which also breaks the IPSec site-to-site VPN. Whatever change you made to fix it in build 2767 needs to be re-added to 7.0.1 before release or people are still going to continue to have trouble after updating.


I’m sorry to bump an old thread but I recently upgraded to version: fw-b305hw2_380hw6_580hw2_710hw3_1350hw2_2500-7.0.0-build1904 and am now having the issue of IPSEC VPN dropouts. The dropouts don’t correspond with internet drop outs. It seems to be a result of the FW upgrade. Is quoted firmware above still the right choice for a solution? Also, if it is, why is the firmware that has the Ipsec issues still on the main site and not this other version?

I have a Peplink Balance 305 HW 2


I would suggest opening ticket for us to take closer look.



Have you found resolution to this post? One thing I had a question about was your Azure network - are you using the Classic or Resource Management deployment models. If I understand it correctly, the Classic networks communicate with Virtual Network Gateways using IKEv1 where the Resource Management networks require IKEv2. One post in the forum suggests that IKEv2 support won’t be seen until the next major firmware version release (7.1.0). We are currently at 7.0.1.

What I am seeing here, is that many of you are already connecting to Azure with version 7.0.1 - but with issues. Might the IKEv issue be of interest here?

I would very much like to establish a viable gateway from my on-prem network to my cloud virt network using the IKEv2 protocol.


I had been experimenting high CPU loads for my peplink router.

Today I found this post and disabled the IPSEC vpns and the cpu load went to 10%, I contacted support but a long time ago about the cpu usage but they never helped with the issue.

I was able to bring back some of the vpn connections using pepvpn but i have some cisco routers that need to connect with IPSEC.

Can somebody help me with this issue?




Initial reported IPSEC issue in the earlier post should be resolved.
For you case, further investigation need to perform from the device to confirm the issue. I will followup with you using support ticket.


I know this is a stale thread, but I had this same behavior. A balance 30, with four IPsec two pepvpn. Reboot, stuck at 100%. I remoted to all the other units and turned off remote side vpns, then with no VPNs running i could finally get back into the pep 30. Then I updated all the ipsec and changed them to IKE2, updated the password (probably didn’t matter). Then I turned them back on one by one to test out. Then I rebooted the unit to make sure it rebooted, re-connected them all fine.


Balance 30 supports 2 IPSec VPN tunnels. This was tested and worked optimum with 2 IPSec VPN tunnnels. I suggest reduce the IPSec VPN tunnel or upgrade to higher model. Please find the link below for more details.