DNS with Active-Active WAN


#1

I recently changed my Drop-in mode configuration from having a Cold-standby to an Active secondary WAN. Since then, my internet has been very slow, which I think is due to DNS issues. What is the proper way to setup DNS with two active WAN ports?


#2

Hello Mlynch1958,

Could you share a little more about your configuration ? do you have any “Outbound” policy created ?


#3

No, I do not have any outbound policies created. I have setup the Balance 580 as the Nameserver for my domain, with the WAN IP’s of both ports configured in the DNS Settings>>>DNS Server dialog box. I have set both connections in the Default Connection Priority as Priority 1. My internal root DNS server is configured to forward to the DNS servers of my two ISPs. Should I have it pointing instead to the WAN IPs of the Balance 580? I tried enabling the Network>>>Service Forwarding>>>DNS Forwarding setup, but that did not work. Email and internet traffic would not pass.


#4

May I know elaborate more details how the traffic slow down?

Regarding the DNS, the “Inbound Access > DNS Settings” is authoritative DNS which is used for inbound load balancing purpose. For my understanding of the issue that you encountered, it is about traffic slow down of outgoing traffic. Therefore, you would no need to use authoritative DNS. Also, I believe your internal DNS is used as DNS resolving purpose. I suggest to forward to LAN IP of Peplink.

In the configuration of Peplink, please make sure the “DNS Proxy” is enable in “Interface > LAN”. DNS Servers in “Interface > WAN (1/2 and so on)” are pointed to the DNS servers which provided by ISP.