disconnect/reconnect or reboot single sim on heath check failure?

Twice this week my max transit cat 18 has gotten “stuck” where computers connected to it show no internet and I can’t ping anything on the Internet. If I leave it alone it works again after an hour or so, but if I power cycle it manually it reconnects to cellular in a minute or so and I can ping again.

I only have one sim in the max transit.

What’s the best way to disconnect and reconnect the cellular wan upon health check failure?
Or even reboot upon health check failure?

Happened again today.

Is there anything I can do with a single SIM that would disconnect/reconnect the cellular wan quickly upon health check failed?

TBH, if it were me I would just disable the health check altogether since you are only using a single SIM/modem.

The whole design of the health check mechanism is so that the unit can quickly failover to a secondary WAN connection. If you only have the one WAN there isn’t much point in using the health check at all.

What would you do when the cellular gets stuck and no data will move? Right now, I walk to the max transit, unplug it from power, and then plug it back in and it’s back online and performing fast.

Is there any other way to set the max transit to disconnect and reconnect the single sim when it can’t pass the health check? (or if the health check can’t be used for this, is there any way to tweak the cellular wan so it would disconnect and reconnect when it’s “stuck”?)

The reason the cellular is getting stuck is because it is failing the health check. If your signal metrics are good then the likely culprit is the DNS servers that are being used for the health checks.

If you are using the default ones provided by the ISP I would definitely change these over to the public Googles ones of 8.8.8.8 and 8.8.4.4. ISP DNS servers can sometimes be very flaky.

Otherwise you could just turn it off altogether and your problem will probably go away.

1 Like

Oh, interesting. I didn’t realize the health check could cause the cellular to get stuck. I already have the pepwave set to use the 8.8.8.8 and 8.8.4.4 dns servers, but I’ll double check and then I’ll try turning health check off and see if it improves. Thanks!

NP let us know how you make out.

Unfortunately, it was not the health check set to smartcheck that was causing the problem as the problem persisted tonight after disabling health check for the cellular wan.

I’ll leave health check disabled as it was not doing anything for me as the only thing I knew to do with it was switch to a second sim for this unit previously when I had a second sim (I’m not using the ethernet wan) and I don’t currently have a second line for it.

The cell signal is not great here. It’s always been difficult, which is actually why I started with the pepwaves. For example, sometimes our phone calls will drop if we walk around the room. Additionally more people have gotten cell boosters this year nearby so that may be causing new interference, I’m not sure.

I’ve tried for now disabling band 12 as I previously ran this max transit at this same location last spring with bands 2, 4, and 66 and it was 100% stable with the same single SIM. I had enabled band 12 for another location. With it enabled here this fall, it was doing LTE-A with 4 bands and delivering 65 instead of 55 mbps with band 12 disabled.

Here’s what the cellular quality looks like here, first with band 12 enabled:

Network
LTE FDD / LTE CA Downlink
Band

LTE Band 12 (700 MHz)
RSSI: -62dBm SINR: 11.9dB RSRP: -94dBm RSRQ: -14.0dB
Secondary Band (SSC1)

LTE Band 2 (1900 MHz)
RSSI: -75dBm SINR: 0.0dB RSRP: -93dBm RSRQ: -3.0dB
Secondary Band (SSC2)

LTE Band 2 (1900 MHz)
RSSI: -77dBm SINR: 0.0dB RSRP: -95dBm RSRQ: -4.0dB
Secondary Band (SSC3)

LTE Band 66 (AWS 1700/2100 MHz)
RSSI: -80dBm SINR: 0.0dB RSRP: -99dBm RSRQ: -3.0dB

and then with band 12 disabled:

Network
LTE FDD / LTE CA Downlink
Band

LTE Band 2 (1900 MHz)
RSSI: -67dBm SINR: 15.2dB RSRP: -93dBm RSRQ: -11.0dB
Secondary Band (SSC1)

LTE Band 2 (1900 MHz)
RSSI: -77dBm SINR: 0.0dB RSRP: -94dBm RSRQ: -3.0dB
Secondary Band (SSC2)

LTE Band 66 (AWS 1700/2100 MHz)
RSSI: -62dBm SINR: 0.0dB RSRP: -92dBm RSRQ: -13.0dB

Network
LTE FDD / LTE CA Downlink
Band

LTE Band 66 (AWS 1700/2100 MHz)
RSSI: -73dBm SINR: 14.5dB RSRP: -98dBm RSRQ: -11.0dB
Secondary Band (SSC1)

LTE Band 2 (1900 MHz)
SINR: 0.0dB RSRP: -44dBm
Secondary Band (SSC2)

LTE Band 2 (1900 MHz)
RSSI: -74dBm SINR: 0.0dB RSRP: -95dBm RSRQ: -7.0dB

Network
LTE FDD / LTE CA Downlink
Band

LTE Band 66 (AWS 1700/2100 MHz)
RSSI: -66dBm SINR: 15.4dB RSRP: -99dBm RSRQ: -12.0dB
Secondary Band (SSC1)

LTE Band 2 (1900 MHz)
SINR: 0.0dB RSRP: -44dBm
Secondary Band (SSC2)

LTE Band 2 (1900 MHz)
RSSI: -78dBm SINR: 0.0dB RSRP: -95dBm RSRQ: -3.0dB

Network
LTE FDD / LTE CA Downlink
Band

LTE Band 66 (AWS 1700/2100 MHz)
RSSI: -70dBm SINR: 13.9dB RSRP: -98dBm RSRQ: -10.0dB
Secondary Band (SSC1)

LTE Band 2 (1900 MHz)
RSSI: -59dBm SINR: 0.0dB RSRP: -90dBm RSRQ: -14.0dB
Secondary Band (SSC2)

LTE Band 2 (1900 MHz)
RSSI: -75dBm SINR: 0.0dB RSRP: -96dBm RSRQ: -7.0dB

There are a number of WAN: Cellular disconnected in SIM slot B and then Cellular connected to ATT within 1 minute in the log, so most of the time it was reconnecting without being noticed that it was down, but sometimes not. If the problem persists with band 12 disabled I will try and see if there is anything in the log for the minutes when it’s “stuck” that is interesting at all, e.g. if it was not disconnected when it was stuck or if it didn’t reconnect within a minute.

Thanks in advance for any thoughts or tips.