Devices connected to router but not the internet

I have a pepwave surf soho, connected to a Zyxel pk5001z from centurylink (my ISP) via a Ethernet cable, I have the wireless radio turned off on my zyxel modem/router. My home security panel is connected to my surf soho router via wifi, and I have a green connected light on my WAN connection. My security panel is not getting through to the internet however. I am not sure if I do not have the surf soho configured properly, or if the zyxel modem is blocking the connection. Any help would be greatyly appreciated.

To troubleshoot, try connecting a device (either your home security panel or a PC) directly to the Zyxel modem and check if you have Internet.

I had the same issue happen to me yesterday with my Surf SOHO MK3. In my case, the problem lies with the Surf not with the modem. I had to restart the Surf 3-4 times before it would reconnect to the modem. In 11 months of use, I have never had a problem until yesterday. And I wasn’t changing any settings/cables/etc.

This issue seems to be similar to the one that’s affecting users of the AP One / AC Mini / Balance 20 described here:

Also while troubleshooting this, I noticed that I am now only getting 20-25 Mbps download speed when connected to the Surf via WiFi. I used to get the full 30 Mbps (still over WiFi), the last time I checked. My WiFi connection to the Surf is 144.5 Mbps so that isn’t the bottleneck. When I connect to the Surf via an Ethernet cable, I get the full 30 Mbps download speed.

Is anyone else having these issues?


Please troubleshoot as suggested by snowman:

  1. Connect a PC to Zyxel modem and check the internet connection.
  2. Connect a PC Via WIFI to Surf SOHO and check the internet connection.

Can you please further confirm your setup ?

1 Like

Thanks for following up on this thread.

My setup is as follows:
Windows 10 PC -> TP-Link TL-WN822N v4.0 wireless 802.11n USB adapter -> Surf SOHO MK3 (HW rev 1) -> Cat 5 Ethernet cable -> Calix GigaPoint 801G fibre modem

The Surf was running firmware 7.0.3 the first time it ever dropped the Internet connection. I had just logged into the Surf web GUI and clicked the “check for firmware update” button (since 7.1.0 had just come out) when it happened. The Surf gave a “no server response”-type error for the firmware update, and I quickly discovered that it had dropped the Internet connection.

My Windows PC remained connected to the Surf via WiFi, though. I was still able to use the web GUI, but in the WAN section it said “Connecting” perpetually and I was unable to access anything on the Internet. Restarting any combination of the GigaPoint and the Surf did not bring the WAN connection back.

When I plugged the PC directly into the GigaPoint, it successfully connected to the Internet. I then plugged the Surf back into the GigaPoint and restarted the Surf a few more times. It still would not establish the WAN connection.

I was out of ideas, so I connected the PC directly to the GigaPoint again and downloaded firmware 7.1.0. Then I upgraded the Surf. It powered up and connected to the Internet!

But then I tried restarting it, and it wouldn’t connect to the Internet again! (Same as before.) It now seems to take about 3 restarts each time before it will connect to the Internet.

For the speed issue, I’ve tried moving the Surf to be right next to my PC and using a different Ethernet cable to the GigaPoint, with no improvement. While connected to the Surf over WiFi at 144.5 Mbps, I only get 20-25 Mbps download speed from the Internet. I used to get the full 30 Mbps through the Surf over WiFi. (FWIW, the Surf’s CPU load goes up to ~50% while running the speed test, which seems kind of high to me.) When I connect the PC to the Surf via an Ethernet cable, I reliably get the full 30 Mbps download speed…so the ISP isn’t the issue.

Neither of these issues existed for the first year that I had the Surf. Other than keeping the firmware up to date, I haven’t changed anything…so I’m confused why these two issues have appeared suddenly.

Thanks again for your help!

Thank you guys for your responses. I was able to connect to the internet via my Zyxel router, I was not able to access the internet via the surf soho via wifi or Ethernet cable. This was true on all my devices, ipad, iPhone, laptop etc… Resetting the router multiple times did not resolve the issue.

This is a new network. I was able to resolve this issue by restoring the factory defaults on the router. When I did this, In Control assigned an IP address to my wifiap. And a range was assigned to each device. Once I had the WIFIAP connected, I was able to reconfigure other settings, back to where I had previously set them (as far as I recollect anyways) and have been able to maintain being able to connect to the internet via both wifi and Ethernet.

@snowman, please fix the WAN port speed and Duplex mode. For the internet speed, what is the guaranteed speed from the ISP? 30Mbps?

1 Like

I connected my PC directly to the GigaPoint to determine its max supported speed, and Windows reported an auto-negotiated speed of 1Gbps full duplex. Then I reconnected the Surf to the GigaPoint and changed its WAN speed from Auto to 1000Mbps full duplex. I restarted the Surf a few times, and every time it came up connected to the Internet. So that change seems to have worked!

It hasn’t had any effect on my download speeds, however. The guaranteed speed from my ISP is 30 Mbps. My WiFi connection speed to the Surf is 144.5 Mbps. But I only get 20-25 Mbps through the Surf (I used to get the full 30 throughout all of last year with this same exact setup). When I ran the speed test tonight, I noticed that the Surf’s CPU load (on the dashboard page) went as high as 83%, which seems high IMO for only transferring data at 25 Mbps. Could this be a clue? I checked the Real-Time Usage Report and it doesn’t report any other network activity.

Thanks again for your support!

I just tried something else:

I rebooted the Surf into firmware 7.0.3. I ran 3 speed tests, and all of them returned 30 Mbps! Then I rebooted back into firmware 7.1.0. I ran 3 more speed tests, and they are all back around 20-25 Mbps.

The new 7.1.0 firmware is the problem.

@snowman, I suspect the there is some config different between v7.0.3 and v7.1.0. Please open ticket for us to take a closer look. Else we will not know what is the problem there.


1 Like

I’ll be happy to open a ticket. But I opened a ticket for this issue a week ago, and it was immediately closed and redirected to 3GStore because I bought the Surf through them. (And I haven’t heard back from them.)

How do I open a ticket and have it be addressed by Peplink? Since this appears to be a firmware issue, it seems like it should go to Peplink not 3GStore.


I also facing the same issue thanks for the suggestion about it hope it helps. :slightly_smiling_face:

You are recommended to look for your purchasing point (our partner) for any technical issue. If the problem is unexpected, the partner will open a ticket with us to continue to investigate.

Since you have done the isolation and the problem looks unexpected, I will follow up with you in the ticket.


1 Like

Firmware 7.1.0 build 1289 has fixed the speed issue. Thanks, TK!

:wink: Glad to hear that!

1 Like

my problem in 8.1.1 firmware is

its connected and we can remote using speed fusion…

but we cant browse no internet access

@erictrejeros, I notice you have a WAN link issue based on what you reported below:

Not sure it is the same issue. I suggest contacting your point of purchase to get support. At least this helps to isolate where the problem is.