Device Connector 300M as WiFi CPE cannot obtain DHCP information


#1

Hi,

Am using the Device Connector 300M as WiFi CPE for a Ethernet only device (PC) but cannot obtain dynamic IP address via DHCP. Now have to configure static IP address for the PC.

Is there any setting to make the DHCP works?

Thanks!


#2

Hello,

Is the Device Connector setup in Bridged Mode or Router Mode? Device Connector will need to be in Router Mode to be able to provide DHCP to the connected clients.


#3

Thanks Jarid,

I’m using Bridge Mode as I would like to use the Device Connector 300M as a layer 2 WiFi CPE so that the PC (without WiFi module) connected to the Ethernet port of the Device Connector can connect to the WiFi infrastructure and obtain DHCP IP address from the DHCP server of the WiFi infrastructure.

Thanks!


#4

Hello Larry

Would you mind share your current configuration of your Device Connector 300M? I have tested on my end, so far i am able to obtain an IP address from the Wi-Fi Infrastucture. I have attached the screen shots of my settings for your references.

Ensure Bridge mode is enabled


Please refer to the highlighted settings


Thank you
Chun Fatt


#5

Thank Chun Fatt,

I am using ‘Bridge Mode’ and having the same settings as your first attachment.

The Device Connector 300m can obtain DHCP IP address from the WiFi infrastructure, however, the PC connected to the Ethernet port of the Device Connector 300M cannot.

In the meantime, I have to use static IP for the PC connected to the Device Connector 300M’s Ethernet port in order to access the network through the WiFi infrastructure. Being able to use DHCP would be nice.

Thanks!


#6

Hi Larry

I would like to review your current settings, please open ticket here and I will assist you further through the ticket.

Thank you
Chun Fatt


#7

Hi Chun Fatt,

Ticket opened with configuration file attached.

Thanks!