Compatibility with Apple's M1 Macbooks

We are running into some compatibility issues where the notebook disconnects intermittently and/or fails to connect altogether. The device is MAX Transit LTE-A, running the latest 8.1.1 RC3 firmware.

We are just starting to troubleshoot, so do not have much additional data to provide yet. It seems that disabling the 5GHz channel and using 2.4GHz only works around the issue. Obviously that’s not a long-term solution.

Has anyone encountered any similar compatibility issues with the M1 Macbooks? If so, what did you do to resolve them?

P.S. There are many threads around WiFi issues with M1s out there, such as Wifi issues? M1 Macbook Pro | MacRumors Forums. I am not making any claims that there is an issue with the Peplink router, as other devices work fine :slight_smile:

No issues with my M1 Air on RC3 firmware

Ok, thanks for the data point. And do you have the 5Ghz band enabled? Using “WPA2/WPA3 Personal” mode for authentication?

Here’s a screenshot of our key settings:

All modern Apple devices are connected to an SSID with WPA3, Fast Switching and 5Ghz only - so everything full speed and no drops between multiple access points…

When you say “5GHz only”, do you mean that your AP is only running 5GHz? Or that the Apple devices are connecting to 5Ghz? Do you have the same name for both frequencies?

In my case the AP name is the same between 2.4GHz and 5GHz. One of the symptoms I’ve seen is that the M1 was bouncing between the two frequencies before I temporarily disabled 2.4GHz.

Correct - I have disabled the 2.4Ghz for that specific SSID as I only use it for modern Apple devices

I have other SSIDs with 2.4Ghz for older wireless devices

1 Like

I suggest using a fixed channel and a fixed channel width. I have no idea if that is the problem, but its better to eliminate them as possibilities.

On the 2.4GHz band, time was that Apple would never use wide channels (40MHz). Don’t know if that is still true, but if the router decides on a non-standard channel width on that band, its asking for trouble.

Apple has a HowTo at

which seems to prefer both 2.4 and 5ghz to be enabled.