Cisco gigabit auto negotiation issues?


#1

I just setup a new Balance 20 router (5.4.9 b1732) for a small remote office, with two Cisco SG300-10 managed switches (latest fw, 1.3.0.62) connected to the Balance 20 LAN ports (1 and 2).

I could not get a L1 physical link with the router and switches in their default configurations. I did not have crossover cables, but the switch (if not the Balance also) supports auto MDI/MDIX so that should not have been an issue. I also disabled STP in the Cisco switches. After no link, I initially forced the port on the Cisco switch to 100M and was able to get a link light and connectivity, but after testing (and very slow internet speeds) determined that the switch was reporting a high level of packets with errors. I tried forcing various duplex, MDI/MDIX, and auto advertisement settings on the Cisco port side but could not clear up the packets with errors.

I reset the Cisco port configuration to default (auto everything), and forced the Balance 20 LAN interface speed to 100M full duplex (advertise speed enabled), and finally was able to get a solid link without errors (though only 100M).

Is anyone aware of gigabit auto negotiation issues with Cisco switches and Balance routers? Are there certain settings required on the Cisco side to work with the Balance 20? I was working with one switch at a time before having success with the Balance 20 forced to 100M, so I don’t think it’s a defective switch (unless I got two bad ones).

Thanks,
Shawn


#2

I know quite a number of customers are using Cisco switches behind Balance and everything works just fine. Could you please go to http://<Your Balance IP>/cgi-bin/MANGA/support.cgi and see if anything stands out?


#3

Hi Kurt, the only thing odd I see on the support page is that the LAN interface is showing status “Link: Down” even though it is online and working. The speed drop-down box is set to 100M-full (advertised). The two Cisco switches are the only devices plugged directly into the LAN ports.

LAN is showing 19 million packets received and 25 million sent (and counting) with zero’s across all error columns.

Thanks,
Shawn


#4

Hi Shawn, so you’ve tried to force the Balance LAN ports to 1000Mbps Full Duplex and you don’t get connectivity?


#5

That is correct, when setting the Peplink to “auto” or 1000M, I wasn’t able to get a link light (or any connectivity) with the switch ports in auto negotiation mode.


#6

In that case, please open up a support ticket so we can take a deeper look in to this:
http://www.peplink.com/contact/support/


#7

I could not get a L1 physical link with the router and switches in their default configurations. I did not have crossover cables, but the switch (if not the Balance also) supports auto MDI/MDIX so that should not have been an issue. I also disabled STP in the Cisco switches. After no link, I initially forced the port on the Cisco switch to 100M and was able to get a link light and connectivity, but after testing (and very slow internet speeds) determined that the switch was reporting a high level of packets with errors. I tried forcing various duplex, MDI/MDIX, and auto advertisement settings on the Cisco port side but could not clear up the packets with errors.


#8

Waleeed, I was able to get mine to work by forcing 100M on the Peplink side (in the hidden support page MANGA/support.cgi). I was under a deadline to get it deployed to a remote location, so I didn’t have time to do any further testing. I have since deployed three other Peplink routers with similar Cisco switches, and the physical links established immediately with no issues. In hindsight, I think was most likely a hardware issue on the Peplink, so I would recommend submitting a support ticket.