Captive portal with PepWave Max BR1 LTE ET


#1

Hi everybody!

It was a pleasure to work with this router (Max BR1 LTE ET) for the last two weeks.
Now I’m trying to set up a custom splash portal, I’m trying to redirect the customer to my web page as soon as he connects to the wifi, the customer can connect to the WiFi, but the redirection fails, The URL in the browser is correct but show an error, “ERR_EMPTY_RESPONSE”, but if I check directly the URL on a internet connected device, It works.

The URL tested is http://www.ohmyfi.com/pep/

This is the Captive portal configuration:


Thanks


#2

Hi,

Please refer here for more details on how Configuring an External Splash Page for Captive Portal.

I noticed attributes included in Step 4 are missing and form is (Step 5) submit to https://device.pepwave.com:8000/cgi-bin/portal.cgi instead of https://captive-portal.peplink.com:8000/portal.cgi. Please ensure form is submitting to https://captive-portal.peplink.com:8000/portal.cgi.

Hope this help.


#3

Hey! thanks for the quick response, I know the form in step 5 isn’t correct(now is correct), but that’s not the problem, I can’t get to Step 4, the server return a white page, using Chrome I see a “ERR_EMPTY_RESPONSE” error. But you can see that the URL is correct and it should be showing that welcome page.
What attributes included in Step 4 are missing? That maybe is the problem, I understand that attributes are created by the AP and sending via URL(GET parameters) I’m right? The mode used is “Open Access”.


#4

Hi,

For the form attibutes, please refer here again.

I have do testing below.

Captive Portal settings


Tested with Internet Explorer


Tested with Chrome


  1. May I know your testing PC is using BR1 LAN IP as DNS server?

  2. Your testing PC ables to resolve www.ohmyfi.com and get response from www.ohmyfi.com?


#5

Hi!
Thanks again for the quick response, I managed to make it work, but I have to use IP instead domain name, I dont know why with 207.58.154.214/pep/ it works but with www.ohmyfi.com/pep/ dont, any clue?. Thanks in advance.

PD: my testing PC uses a public DNS, not the AP as DNS.


#6

Hi,

Please use BR1 LAN IP as your testing PC DNS server. Please ensure DNS proxy is enabled (Network > Basic Settings > DNS Proxy Settings > Enable = Check) in BR1.


#7

Hi, this is my DNS Proxy Settings:


I managed to set up the configuration to work with my server and now everything it’s working perfectly but using IP address, I still have no idea why is not working with domain name. Last try was to include Google Public DNS servers but with no luck.
Thanks


#8

Hi,

As suggested on my post here, please use BR1 LAN IP as your testing PC DNS server instead of public DNS.


#9

Thank you again,
I don’t know if that’s the problem:
I have tried setting up the testing PC with many DNS, Public DNS, 192.168.50.1 (AP), Automatic. But no luck. Maybe I’m not understanding you, what do you mean when you say that I should use BR1 LAN IP as DNS?. I have tried many devices too, a smartphone, another laptop, a tablet and got the same result “ERR_EMPTY_RESPONSE”. When I check the wireless connection details, the DNS is the same as Default Gateway, is this OK?
I changed the configuration of testing-PC to automatic, I think this is not problem of the testing device because other devices can’t make it work either, I believe the misconfiguration is in the Pepwave.
Sorry if I don’t understand you, can you show me where to set this up?


#10

Hi,

If testing PC’s DNS sets to Automatic should be fine. You should get 192.168.50.1 with default settings on BR1.

Your problem is strange. It should be realated to DNS problem since IP is working fine. I tested it is working fine in my lab as posted here. I suggest to open ticket for us to take closer look on this unit.

Thank you.


#11

Hi!
It’s me again, just for close the thread, the problem was de AP, when tried the exact same conf with another AP it worked just fine. Maybe firmware bug? I don’t know, the bad AP was returned to the seller.
Thats All, Thanks!