Best setting for straight IP passthrough?

We have a Pepwave MAX Transit 5g setup with…
WAN - 350/350 hardline internet
CELLULAR - ATT cellular.

We have it set to do IP passthrough to a firewall/router. Functionally it works. The failover works good and gives the firewall the correct “IP passthrough” IP address via DHCP.

Performance wise something is up…
We noticed that the latency just wasn’t right, compared to bypassing the pep wave.
We got 8-10MS pings consistently to 8.8.8.8 when using a laptop direct to our internet provider.
We got 8-400MS pings randomly when going through the pepwave in IP passthrough. 8ms for a bit… but it spikes now and again to 100ms… sometimes 400ms…

I noticed the “outbound policy” was set the auto. When I changed this to “priority” it seemed to help a TON with the latency. Why is this? What is “auto” doing that making the latency bad? Should it be set to priority mode when using cellular as failover?

We basically want the pepwave to ONLY do failover dual interner (IP passthrough). nothing else…

Basically - Are there any other settings we can turn off to boost performance when doing DUAL wan failover in IP passthrough mode? (Dual wan being a hardline connection and built in cellular)