BalanceTwo: Issues with setting Trunk on select VLANs

Hi, I’m trying to send the Untagged default VLAN to Port1 and all other Tagged VLANs to Port2. Just testing with two networks (Untagged-VLAN10 and Tagged-VLAN2) works if both Port1 and Port2 are configured as Access. If i then change the Port2 to Trunk and select only the VLAN2 I seem to lose the ability to access the default Untagged-VLAN10 on any port.

Note that Port3/4 are not used / disconnected.

Any help appreciated.



Switches use untagged traffic for several communication protocols that don’t support tagging. So it may be best to allow both VLANs between the Peplink and the switch, then limit the traffic using the switch configuration alone.

1 Like

Let me read this back to you. Are you saying that in the above pictured configuration, if you plug a laptop into LAN1 it can not get access to LAN10? I assume LAN10 has DHCP enabled, and anyway you said it does work when you connect to LAN1 when LAN2 is set to access (on VLAN2).

If so that feels like a bug to me and you should log a ticket.

1 Like

I do have a separate management network with dedicated hardware for this.

Just to clarify - there are two LANs:

  • LAN10 is untagged and has for the sake of argument IP addresses in the range 10.10.10.x
  • LAN2 is tagged and has IP addresses in the range 10.10.2.x
    Both LANs have DHCP enabled, and yes I am testing by plugging a PC directly into the ports. The operation seems unexpected that Port1 seems like it stops working all together - I can’t ping the router interface (ie Port2 works better so when setting VLANID=2 on the PC network adapter configuration i can communicate on the LAN2 subnet.

OK, that seems like it to me as well, thanks. I did notice a new FW version today though, so i will probably try that first.

After some debug, it appears that changing these settings does require a system reboot, which explains the instability i was seeing.

However, and maybe this is intentional, the default LAN is present on a Trunk Port even if it is not selected. So with the setup mentioned at the top, the untagged “LAN10” is present on both Port1 and Port2, so that custom filter is not working as it relates to the untagged LAN.

This is in itself a bug as far as I’m concerned. Do log it as a ticket - it deserves investigation as to why a reboot is required.

1 Like


I tried to simulate your configuration but i can’t really see the instability issue as mentioned that require to reboot the Balance Two inoder the settings will take effect. Would you able to share me the steps how to trigger the problem that you need to reboot the device inorder the configuration will take effect ?

Tested this and look like this may be a bug. I will confirm again after discussed with Engineering team.