Balance One Core Underperforming Throughput

I have had a Balance One Core in place for a little over a year. I upgraded from the Surf SOHO. We increased our cable speed from 100Mbps to 400Mbps and I needed a router that supported more throughput. Originally it performed very well. We were able to pull down about 450Mpbs consistently. However, recently the throughput dropped to about 260Mpbs. I’m not exactly sure when it happened. I know it is not Spectrum (for once) because when I connect my desktop directly to the cable modem, I can pull down close to 500Mbps. I’ve tried unplugging everything from the router except for the desktop. I’ve tried disabling the PepVPN tunnels. I even tried downgrading the firmware back to 8.0.1. I can still only pull down 260Mbps. I’m super disappointed. Does anyone have any suggestions as to what the problem may be?

I just upgraded to firmware 8.1 RC1 as an experiment. The throughput increased to 280Mbps and seems more stable, but this is still no where near what is used to be.

I’m having a similar issue with the Balance One as well. We have Comcast 1Gbps tier. Used to be able to get over 600Mbps download through the router. Now I’m capping out around 350Mbps. Not sure when it started for sure. I’ve just recently noticed it. I can hook the Comcast up direct to a device not going through the Peplink and get over 900Mbps with no issues. I’m thinking of purchasing a Balance Two but don’t want to end up with similar issues.

Just to rule it out, I got a new modem from my ISP, and that still did not correct the bandwidth issue. This made me very frustrated, so I figured I would reset the Balance One to the factory settings and run the speed test. Boom! The bandwidth is back to 450+ Mbps. Now I know that it must be a setting. I put my configuration back in one setting at a time testing the bandwidth after each setting was applied. QoS is the problem. Whenever any QoS setting is applied, the bandwidth is essentially cut in half. I’m not sure if this is Peplink’s implementation of QoS, or if it is a firmware bug. If it is a bug, I am unsure how to report it. If this is by design, I believe it to be a poor choice. At a minimum, I would recommend that it be documented in big bold letters, “If you turn this on, your bandwidth for all other applications will be reduced dramatically!”


I’m having a similar issue, but have not found a solution.


  • Balance One, running firmware 8.1.0 RC2 and RC3
  • the internal WiFi AP is disabled, but it is managing 3 Peplink AP One Minis
  • a cable modem with 480/20 speeds


  • with a direct ethernet connection to the modem, I get 480/20
  • when running through the Balance One, I get 240mbps
  • the balance CPU usage is mostly in the 50% to 75% range during the speed test

However, unlike your experience, I can’t seem to find any setting that is causing the slowdown.

Things I’ve tried:

  • QoS / Application / DSL/Cable Optimization: ON or OFF
  • Support / Mitigate Bufferbloat: Enable of Disable
  • Support / [Experimental] WAN connection buffer size (Default=2000, 500, 4000)
  • Inbound firewall rules: Disabled
  • Outbound policy : Custom (Least Used) or Auto
  • Bounjour Forwarding: On or Off
  • DNS Cacing: On or Off

It’s weird: not only is my bandwidth “cut in half”, it’s almost exactly cut in half (480mbps → 240mbps). This could be a coincidence but seems a little suspicous.

Other things about my setup:

  • Inbound Access / Port Forwarding: I have 18 rules
  • NAT Mapping: I have 1 defined
  • 2 VLANs defined
  • 2 WANs + one Verizon hotspot (in cold standby)
  • My balance one does not have the “LAN as WAN license”
  • IPv6 : Disabled

I’m not sure when this started, but I feel like it was when I started testing the 8.1 betas, but I couldn’t say for sure.

1 Like

In my case, I did some further troubleshooting. The specific offending setting that cut my bandwidth dramatically was Network->QoS->Application. Remote Access specifically Remote Desktop was added with High Priority. As soon as I removed it, my bandwidth performed as expected.

1 Like

I’ve run some other tests, and nothing so far has fixed the issue:

  1. As per @ oakhurstmgmt, I set up QoS with a custom TCP443 rule set to “High” or “Low” priority, and tested with no rule at all.
  2. Disabled all of my Oubound policy rules
  3. Removed my NAT mapping rule.
  4. Disabled Remote User Access (PPTP VPN server)
  5. turned off WAN Quality Monititoring

Hmm - I see a couple of weird things.

First, on the support page:

Notice how it’s showing LAN 1 as WAN, LAN2 as WAN, etc.? I never paid for that license.

Second, I’m seeing here

it shows the router throughput for my Balance One as 400mbps. The specification was 600mbps when I purchased it:

I assume that’s a typo as it still shows up as 600mbps on the peplink store:


It’s the weekend, so I’m able to do more testing now. I feel like I’m closing in on the issue with some more tests.

To recap - this is a Balance One, with 2 WANs, one of which is a Spectrum cable modem which is provisioned for 480mbps download speeds. With latest firmware, I’m not able to get advertised speeds. Unlike other users, I have not found a specific setting with 8.1 that is causing the speed loss…

This morning I ran tests using old firmware versions, and the results are illuminating:

Speed    CPU      Firmware      Comments
480mbps             7.1.2         full speed
480mbps  97%        8.0.0         full speed - CPU is maxxed out
240mbps  70%        8.0.1         about half speed - CPU is not maxxed out
240mbps             8.0.2         about half speed
240mbps             8.1.0 RC3     about half speed

From this testing, the problem is not new, but rather shows up in the jump between firmware 8.0.0 and 8.0.1.

Looking at the 8.0.1 release notes ( ) and thinking about what features I’m using or that could conceivably cause a system-wide performance decline, I found these:

18627 [AP Controller]​ Added Fast Roaming 802.11k, 802.11r, 802.11v support
Comment: I am using fast roaming, although since all my tests are over Ethernet, I don’t think this is likely to be causing an Ethernet slowdown.

20896 [Firewall]​ Local Service Inbound Firewall support
Comment: I am using local service firewall rules. I’ve tested with them disabled and seen no changes, but this still could be relevant.

20822 [QoS]​ Added Youtube and Netflix applications.
Comment: I’m not using any QoS settings, but user oakhurstmgmt has reported these are causing the problem for them.

21161 [SNMP]​ SNMPv3 Authentication and Privacy passphrase supporting special characters
Comment: I am using SNMP, but I’m not using SNMPv3, but perhaps some code changes in SNMP are causing trouble?

20998 [System]​ Fixed for TCP SACK CVE-2019-11477 CVE-2019-11478 CVE-2019-11479
Comment: any chance these fixes broke somethign with TCP ACKs? Suppose every other ACK was getting lost or delayed, that could explain a 50% download speed loss.

Next tests: I’ll go to 8.1 RC4 and see if I can factory reset and add my settings back one-by-one as oakhurstmgmt has done above.

Edit : Found the bug. See Outbound Policy Rule using Domain Name cuts bandwidth in half


@soylentgreen, we have responded you below.

1 Like

Is this a CPU issue ( throttling GHz) ? Because the temperature of the box is high? Did you try to keep the box in a low temperature ambient? Using some external fan?

It’s not a CPU or Temperature issue based on my test results. Please see Outbound Policy Rule using Domain Name cuts bandwidth in half - #7 by Lai for follow info.

1 Like

Thank you. I already saw it. But just thinking… because it is a very hot box.

I’m sorry but I have to bring this topic up again.
BPL-ONE-CORE, FW 8.1.1, no outbound policies or anythink like this.

untagged LAN: 550Mbit/s
VLAN 10 (with InControl CaptivePortal): 270Mbit/s

The Ethernet Port with VLAN10 is configured as an Access Port.
Just resetted the device to factory defaults, without any luck. Did anyone experienced something like this?

Don’t waste time testing of trying, this device is way under-performed as per advertised spec, if you are lucky and turn off all configs/rules/monitoring & etc, you might be able to get higher throughput and that only applies when you only have ONE WAN. I had the same issue and feel like cheated on getting this device!


I’m the one that working on your ticket. As discussed in the ticket, we are investigating the issue why your application cannot get higher performance. Beside that, we also discussed with QA team and the test results is positive. Please refer to the attached screenshot for the reverted test results and the session generated for the test results.

For the application low performance issue, we still need to further investigate and hope you can work with us to identify the issue.

1 Like